Lintian ReportsBETA

Wtypelib-package-name-does-not-match

Tag versions

The tag is present in Lintian version 2.104.260. That is the most recent version we know about.

GObject-Introspection binary typelibs (Foo-23.typelib) should normally be made available in a package named gir1.2-foo-23.

If multiple typelibs are shipped in the same package, then that package should have versioned Provides for the names that would have been used for separate packages. This arrangement should only be used if the included typelibs' versions are expected to remain the same at all times.

For example, gir1.2-gtk-3.0 is named for the Gtk-3.0 typelib, but also contains the Gdk-3.0 and GdkX11-3.0 typelibs. It should have versioned Provides entries for gir1.2-gdk-3.0 (= ${binary:Version}) and gir1.2-gdkx11-3.0 (= ${binary:Version}) to indicate this.

Refer to /usr/share/doc/gobject-introspection/policy.txt for details.

Visibility: warning

Check: desktop/gnome/gir

The following 23 source packages in the archive triggered the tag 56 times.

We found 7 overrides. The tag performed 88% of the time.