Lintian Reports

W symbols-file-contains-debian-revision

All reports of symbols-file-contains-debian-revision for the archive. The extended description of this tag is:

Debian revisions should be stripped from versions in symbols files. Not doing so leads to dependencies unsatisfiable by backports (1.0-1~bpo << 1.0-1 while 1.0-1~bpo >= 1.0). If the Debian revision can't be stripped because the symbol really appeared between two specific Debian revisions, you should postfix the version with a single "~" (example: 1.0-3~ if the symbol appeared in 1.0-3).

Refer to the dpkg-gensymbols(1) manual page and https://wiki.debian.org/UsingSymbolsFiles for details.

Severity: normal, Certainty: certain

Check: shared-libs, Type: binary, udeb

Emitted (non-overridden): 17, overridden: 4, total: 21

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

lib32z1 1:1.2.11.dfsg-1+b1 (binary) (Mark Brown <broonie@debian.org>)

lib64z1 1:1.2.11.dfsg-1+b1 (binary) (Mark Brown <broonie@debian.org>)

libchasen2 2.4.5-44+b1 (binary) (Natural Language Processing (Japanese) <team+pkg-nlp-ja@tracker.debian.org>)

libexttextcat-2.0-0 3.4.5-1 (binary) (Debian LibreOffice Maintainers <debian-openoffice@lists.debian.org>) overridden

libflite1 2.1-release-3 (binary) (Debian Accessibility Team <pkg-a11y-devel@lists.alioth.debian.org>)

libgssapi-krb5-2 1.17-6 (binary) (Sam Hartman <hartmans@debian.org>) overridden

libhdf5-103 1.10.4+repack-10 (binary) (Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>)

libhdf5-103 1.10.5+repack-1~exp5 (binary) (Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>)

libhdf5-cpp-103 1.10.4+repack-10 (binary) (Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>)

libhighwayhash0 0~git20191002.0aaf66b-1 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libksba8 1.3.5-2 (binary) (Debian GnuTLS Maintainers <pkg-gnutls-maint@lists.alioth.debian.org>)

libmonoboehm-2.0-1 5.18.0.240+dfsg-5 (binary) (Debian Mono Group <pkg-mono-group@lists.alioth.debian.org>)

libmonosgen-2.0-1 5.18.0.240+dfsg-5 (binary) (Debian Mono Group <pkg-mono-group@lists.alioth.debian.org>)

libpcre16-3 2:8.39-12+b1 (binary) (Matthew Vernon <matthew@debian.org>)

libpcre32-3 2:8.39-12+b1 (binary) (Matthew Vernon <matthew@debian.org>)

libpcrecpp0v5 2:8.39-12+b1 (binary) (Matthew Vernon <matthew@debian.org>)

libpsm2-2 11.2.86-1 (binary) (Debian HPC Team <debian-hpc@lists.debian.org>) overridden

libpugixml1v5 1.9-3 (binary) (Vasudev Kamath <vasudev@copyninja.info>)

libstdc++5 1:3.3.6-30 (binary) (Philipp Kern <pkern@debian.org>)

zlib1g 1:1.2.11.dfsg-1+b1 (binary) (Mark Brown <broonie@debian.org>)