Lintian Reports

W symbols-declares-dependency-on-other-package

All reports of symbols-declares-dependency-on-other-package for the archive. The extended description of this tag is:

This package declares in its symbols control file a dependency on some other package (and not one listed in the Provides of this package).

Packages should normally only list in their symbols control file the shared libraries included in that package, and therefore the dependencies listed there should normally be satisfied by either the package itself or one of its Provides.

In unusual circumstances where it's necessary to declare more complex dependencies in the symbols control file, please add a Lintian override for this warning.

Refer to Debian Policy Manual section 8.6 (Dependencies between the library and other packages) for details.

Severity: normal, Certainty: possible

Check: shared-libs, Type: binary, udeb

Emitted (non-overridden): 9, overridden: 92, total: 101

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

libaprutil1 1.6.1-4+b1 (binary) (Debian Apache Maintainers <debian-apache@lists.debian.org>) overridden

libblis2-openmp 0.6.0-2 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libblis2-pthread 0.6.0-2 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libblis2-serial 0.6.0-2 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libblis64-2-openmp 0.6.0-2 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libblis64-2-pthread 0.6.0-2 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libblis64-2-serial 0.6.0-2 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libcvc0 4.2.0-2 (binary) (Debian Cinnamon Team <debian-cinnamon@lists.debian.org>) overridden

libdrm-nouveau2 2.4.99-1 (binary) (Debian X Strike Force <debian-x@lists.debian.org>) overridden

libefreet1a 1.22.3-1 (binary) (Debian Pkg-e Team <pkg-e-devel@lists.alioth.debian.org>) overridden

libegl1-nvidia 430.50-1 (binary) (Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>) overridden

libegl1-nvidia-legacy-340xx 340.107-7 (binary) (Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>) overridden

libegl1-nvidia-legacy-390xx 390.129-1 (binary) (Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>) overridden

libethumb-client1 1.22.3-1 (binary) (Debian Pkg-e Team <pkg-e-devel@lists.alioth.debian.org>) overridden

libgail18 2.24.32-4 (binary) (Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>) overridden

libgbm1 19.2.1-1 (binary) (Debian X Strike Force <debian-x@lists.debian.org>) overridden

libgconf-2-4 3.2.6-6 (binary) (Adrian Bunk <bunk@debian.org>)

libgl1-nvidia-glx 430.50-1 (binary) (Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>) overridden

libgl1-nvidia-legacy-304xx-glx 304.137-7 (binary) (Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>) overridden

libgl1-nvidia-legacy-340xx-glx 340.107-7 (binary) (Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>) overridden

libgl1-nvidia-legacy-390xx-glx 390.129-1 (binary) (Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>) overridden

libgles1-nvidia-legacy-340xx 340.107-7 (binary) (Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>) overridden

libgles2-nvidia-legacy-340xx 340.107-7 (binary) (Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>) overridden

libkf5emoticons5 5.62.0-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>)

libkf5globalaccel5 5.62.0-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>)

libkf5grantleetheme5 18.08.3-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>)

libkf5kiocore5 5.62.1-2 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libkf5kiofilewidgets5 5.62.1-2 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libkf5kiowidgets5 5.62.1-2 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libkf5libkdepim5 4:18.08.3-2 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>)

libkf5package5 5.62.0-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>)

libkf5purpose5 5.62.0-2 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libkf5screen7 4:5.14.5-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>)

libkf5service5 5.62.0-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>)

libkf5wallet5 5.62.0-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>)

libmbim-glib4 1.18.2-0.2 (binary) (Mathieu Trudel-Lapierre <cyphermox@ubuntu.com>) overridden

libpixman-1-0 0.36.0-1 (binary) (Debian X Strike Force <debian-x@lists.debian.org>) overridden

libqmi-glib5 1.22.4-0.1 (binary) (Mathieu Trudel-Lapierre <mathieu.tl@gmail.com>) overridden

libqt5concurrent5 5.12.5+dfsg-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5concurrent5 5.11.3+dfsg1-4 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5dbus5 5.12.5+dfsg-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5dbus5 5.11.3+dfsg1-4 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5gui5 5.12.5+dfsg-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5gui5 5.11.3+dfsg1-4 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5gui5-gles 5.12.4+dfsg-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5network5 5.12.5+dfsg-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5network5 5.11.3+dfsg1-4 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5opengl5 5.12.5+dfsg-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5opengl5 5.11.3+dfsg1-4 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5printsupport5 5.12.5+dfsg-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5printsupport5 5.11.3+dfsg1-4 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5quick5 5.11.3-4 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5quick5 5.12.5-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5quickparticles5 5.11.3-4 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5quickparticles5 5.12.5-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5quickshapes5 5.12.5-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5quicktest5 5.11.3-4 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5quicktest5 5.12.5-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5quickwidgets5 5.11.3-4 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5quickwidgets5 5.12.5-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5scripttools5 5.11.3+dfsg-3 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5scripttools5 5.12.4+dfsg-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5sql5 5.12.5+dfsg-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5sql5 5.11.3+dfsg1-4 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5test5 5.12.5+dfsg-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5test5 5.11.3+dfsg1-4 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5webengine5 5.12.5+dfsg-2 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5webenginewidgets5 5.12.5+dfsg-2 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5widgets5 5.12.5+dfsg-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5widgets5 5.11.3+dfsg1-4 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5xml5 5.12.5+dfsg-1 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqt5xml5 5.11.3+dfsg1-4 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libqtdbus4 4:4.8.7+dfsg-19 (binary) (Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libserf-1-1 1.3.9-7+b10 (binary) (James McCoy <jamessan@debian.org>) overridden

libstartup-notification0 0.12-6 (binary) (Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>) overridden

libtag1v5-vanilla 1.11.1+dfsg.1-0.3+b1 (binary) (Modestas Vainius <modax@debian.org>) overridden

libx11-6 2:1.6.8-1 (binary) (Debian X Strike Force <debian-x@lists.debian.org>) overridden

libxine2-bin 1.2.9-1+b3 (binary) (Debian QA Group <packages@qa.debian.org>) overridden

nvidia-libopencl1 435.21-1 (binary) (Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>) overridden

nvidia-libopencl1 430.50-1 (binary) (Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>) overridden