Lintian Reports

W shlib-without-versioned-soname

All reports of shlib-without-versioned-soname for the archive. The extended description of this tag is:

The listed shared library in a public library directory has an SONAME that does not contain any versioning information, either after the .so or before it and set off by a hyphen. It cannot therefore be represented in the shlibs system, and if linked by binaries its interface cannot safely change. There is no backward-compatible way to migrate programs linked against it to a new ABI.

Normally, this means the shared library is a private library for a particular application and is not meant for general use. Policy recommends that such libraries be installed in a subdirectory of /usr/lib rather than in a public shared library directory.

To view the SONAME of a shared library, run readelf -d on the shared library and look for the tag of type SONAME.

There are some special stub libraries or special-purpose shared objects for which an ABI version is not meaningful. If this is one of those cases, please add an override.

Refer to Debian Policy Manual section 10.2 (Libraries) and Debian Policy Manual section 8.6 (Dependencies between the library and other packages) for details.

Severity: normal, Certainty: possible

Check: shared-libs, Type: binary, udeb

Evolution of the shlib-without-versioned-soname Lintian tag over the past 366 days:

The beforementioned graph for the shlib-without-versioned-soname tag

Emitted (non-overridden): 113, overridden: 332, total: 445

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

amarok 2.9.0-1+b1 (binary) (Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>) overridden

baycomepp 0.10-15 (binary) (Debian Hamradio Maintainers <debian-hams@lists.debian.org>)

calligraplan 1:3.1.0-3+b1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

calligrasheets 1:3.1.0+dfsg-4 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

calligrastage 1:3.1.0+dfsg-4 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

calligrawords 1:3.1.0+dfsg-4 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

cantor 4:18.08.1-1+b1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

cervisia 4:17.08.3-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

clazy 1.4-3 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

cvsservice 4:17.08.3-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

dolphin 4:18.08.0-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

feedreader 2.2-1 (binary) (Ulises Vitulli <dererk@debian.org>)

gdbserver 8.2-1 (binary) (Héctor Orón Martínez <zumbi@debian.org>)

globus-gram-job-manager-fork-setup-seg 3.0-1 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

globus-gram-job-manager-lsf-setup-seg 3.0-1 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

globus-gram-job-manager-pbs-setup-seg 3.0-1 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

globus-gram-job-manager-sge-setup-seg 3.0-1 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

globus-seg-job-manager 15.1-2 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

htcondor 8.6.8~dfsg.1-2+b1 (binary) (HTCondor Developers <condor-debian@cs.wisc.edu>)

intel-gpu-tools 1.22-1+b1 (binary) (Debian X Strike Force <debian-x@lists.debian.org>) overridden

kactivitymanagerd 5.14.3-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>)

karbon 1:3.1.0+dfsg-4 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kcalc 4:18.04.1-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kde-cli-tools 4:5.14.3-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kde-runtime 4:17.08.3-2 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kde-telepathy-text-ui 17.08.3-2 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kded5 5.51.0-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kdevelop 4:5.3.0-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kdevelop 4:5.2.4-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kdevelop-php 5.3.0-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kdevelop-php 5.2.4-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kdevelop-python 5.3.0-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kdevelop-python 5.2.4-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

khelpcenter 4:18.04.0-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kile 4:2.9.92-1 (binary) (Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>) overridden

kinit 5.51.0-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kmenuedit 4:5.14.3-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kmix 4:18.04.1-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kmplayer 1:0.12.0b-3 (binary) (Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>) overridden

konqueror 4:18.04.0-1+b2 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>)

konsole 4:18.04.0-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kopete 4:18.08.3-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kopete 4:17.08.3-2 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kpat 4:18.04.1-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

ksysguard 4:5.14.3-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kup-backup 0.7.1+dfsg-1+b1 (binary) (Thomas Pierson <contact@thomaspierson.fr>) overridden

kwin-common 4:5.14.3-2 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

kwin-x11 4:5.14.3-2 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libblasr 5.3.1+dfsg-1+b1 (binary) (Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>)

libc6 2.28-2 (binary) (GNU Libc Maintainers <debian-glibc@lists.debian.org>)

libc6-amd64 2.28-2 (binary) (GNU Libc Maintainers <debian-glibc@lists.debian.org>)

libc6-i386 2.28-2 (binary) (GNU Libc Maintainers <debian-glibc@lists.debian.org>)

libc6-x32 2.28-2 (binary) (GNU Libc Maintainers <debian-glibc@lists.debian.org>)

libcantor-pythonbackend 4:18.08.1-1+b1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

libcentreon-clib 18.10.0-1 (binary) (Freexian Packaging Team <team+freexian@tracker.debian.org>)

libcg 3.1.0013-4 (binary) (Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>) overridden

libcggl 3.1.0013-4 (binary) (Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>) overridden

libcoda-jni 2.19-2+b2 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>)

libelektra4 0.8.14-5.1 (binary) (Pino Toscano <pino@debian.org>)

libglobus-common0 18.0-2 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

libglobus-gridmap-eppn-callout 2.0-1 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

libglobus-gridmap-verify-myproxy-callout 3.0-1 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

libglobus-xio-gridftp-driver 3.1-1 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

libglobus-xio-gridftp-multicast 2.0-1 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

libglobus-xio-gsi-driver 5.0-1 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

libglobus-xio-net-manager-driver 1.1-1 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

libglobus-xio-pipe-driver 4.0-1 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

libglobus-xio-popen-driver 4.0-1 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

libglobus-xio-rate-driver 2.0-1 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

libglobus-xio-udt-driver 2.0-1 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

libhx-dev 3.23-1 (binary) (Jörg Frings-Fürst <debian@jff.email>)

libib-util 3.0.5.33083.ds4-1 (binary) (Damyan Ivanov <dmn@debian.org>) overridden

libimage-transport0d 1.11.13-2+b2 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>)

libmkl-vml-avx 2019.0.117-3 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libmkl-vml-avx2 2019.0.117-3 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libmkl-vml-avx512 2019.0.117-3 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libmkl-vml-avx512-mic 2019.0.117-3 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libmkl-vml-cmpt 2019.0.117-3 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libmkl-vml-def 2019.0.117-3 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libmkl-vml-ia 2019.0.117-3 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libmkl-vml-mc 2019.0.117-3 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libmkl-vml-mc2 2019.0.117-3 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libmkl-vml-mc3 2019.0.117-3 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libmkl-vml-p4 2019.0.117-3 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libmkl-vml-p4m 2019.0.117-3 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libmkl-vml-p4m2 2019.0.117-3 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libmkl-vml-p4m3 2019.0.117-3 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

libmyproxy-voms 6.2.3-1 (binary) (Mattias Ellert <mattias.ellert@physics.uu.se>) overridden

libnspr4 2:4.20-1 (binary) (Maintainers of Mozilla-related packages <team+pkg-mozilla@tracker.debian.org>) overridden

libnss3 2:3.41-1 (binary) (Maintainers of Mozilla-related packages <team+pkg-mozilla@tracker.debian.org>) overridden

libo2 1.0~repack-1 (binary) (Debian Multimedia Maintainers <debian-multimedia@lists.debian.org>)

libodb-api-0d 0.18.0-7 (binary) (Alastair McKinstry <mckinstry@debian.org>)

libpbbam 0.7.4+ds-1+b1 (binary) (Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>) overridden

libpbdata 5.3.1+dfsg-1+b1 (binary) (Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>)

libpbihdf 5.3.1+dfsg-1+b1 (binary) (Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>)

libphp7.3-embed 7.3.0-1 (binary) (Debian PHP Maintainers <team+pkg-php@tracker.debian.org>) overridden

libsbml5-java 5.16.0+dfsg-2 (binary) (Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>) overridden

libseed-gtk4-0 4.0.0+20161014+6c77960+dfsg1-5+b1 (binary) (Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>)

libsss-sudo 1.16.3-3 (binary) (Debian SSSD Team <pkg-sssd-devel@alioth-lists.debian.net>) overridden

libstd-rust-1.29 1.29.0+dfsg1-1 (binary) (Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>) overridden

libstd-rust-1.30 1.30.0+dfsg1-2 (binary) (Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>) overridden

libstd-rust-1.31 1.31.0~beta.4+dfsg1-1~exp1 (binary) (Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>) overridden

libstd-rust-1.31 1.31.0~beta.4+dfsg1-1~exp2 (binary) (Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>) overridden

libtcl8.6 8.6.9+dfsg-1 (binary) (Debian Tcl/Tk Packagers <pkg-tcltk-devel@lists.alioth.debian.org>) overridden

libtcl8.7 8.7.0~a1+dfsg-4 (binary) (Debian Tcl/Tk Packagers <pkg-tcltk-devel@lists.alioth.debian.org>) overridden

libtk8.6 8.6.9-1 (binary) (Debian Tcl/Tk Packagers <pkg-tcltk-devel@lists.alioth.debian.org>) overridden

libtk8.7 8.7.0~a1-5 (binary) (Debian Tcl/Tk Packagers <pkg-tcltk-devel@lists.alioth.debian.org>) overridden

libusb-java-lib 0.8+ztex20090101-7 (binary) (Steffen Moeller <moeller@debian.org>)

libvulkan1 1.1.73+dfsg-1 (binary) (Debian X Strike Force <debian-x@lists.debian.org>)

libwiredtiger0 3.1.0+ds-1 (binary) (Laszlo Boszormenyi (GCS) <gcs@debian.org>)

marble-plugins 4:17.08.3-3.1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>)

marble-plugins 4:18.08.0-0~exp0+nmu1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>)

mesa-vulkan-drivers 18.3.0-1 (binary) (Debian X Strike Force <debian-x@lists.debian.org>) overridden

mesa-vulkan-drivers 18.2.6-1 (binary) (Debian X Strike Force <debian-x@lists.debian.org>) overridden

mlterm-common 3.8.6-2 (binary) (Kenshi Muto <kmuto@debian.org>)

mono-runtime-common 4.6.2.7+dfsg-2 (binary) (Debian Mono Group <pkg-mono-group@lists.alioth.debian.org>)

opensc-pkcs11 0.19.0-1 (binary) (Debian OpenSC Maintainers <pkg-opensc-maint@lists.alioth.debian.org>)

phylip 1:3.697+dfsg-1 (binary) (Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>) overridden

plasma-desktop 4:5.14.3-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

plasma-nm 4:5.14.3-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

plasma-workspace 4:5.14.3-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

plasma-workspace 4:5.14.3-1+b1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

print-manager 4:18.04.1-1 (binary) (Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>) overridden

python-vmtk 1.3+dfsg-2.3 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>) overridden

renderdoc 1.2+dfsg-1 (binary) (Debian X Strike Force <debian-x@lists.debian.org>) overridden

rviz 1.13.1+dfsg-1+b2 (binary) (Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>)

tcl-itcl4 4.1.2-1 (binary) (Debian Tcl/Tk Packagers <pkg-tcltk-devel@lists.alioth.debian.org>) overridden

tk-itk4 4.1.0-3 (binary) (Debian Tcl/Tk Packagers <pkg-tcltk-devel@lists.alioth.debian.org>) overridden

virtualbox-guest-x11 5.2.22-dfsg-2 (binary) (Debian Virtualbox Team <team+debian-virtualbox@tracker.debian.org>) overridden