Lintian ReportsBETA

Wshared-library-lacks-prerequisites

Tag versions

The tag is present in Lintian version 2.104.234. That is the most recent version we know about.

The listed shared library doesn't include information about the other libraries against which it was linked.

More specifically, "ldd foo.so" should report such other libraries. In your case, it reports "statically linked".

The fix is to specify the libraries. One way to do so is to add something like "-lc" to the command-line options for "ld".

Visibility: warning

Check: binaries

The following 314 source packages in the archive triggered the tag 1163 times.

We found 235 overrides. The tag performed 80% of the time.