Lintian Reports

W script-uses-deprecated-nodejs-location

All reports of script-uses-deprecated-nodejs-location for the archive. The extended description of this tag is:

You used /usr/bin/nodejs or /usr/bin/env nodejs as an interpreter for a script.

The /usr/bin/node binary was previously provided by ax25-node and packages were required to use /usr/bin/nodejs instead. ax25-node has since been removed from the archive and the nodejs package now ships the /usr/bin/node binary to match the rest of the Node.js ecosystem.

Please update your package to use the node variant.

Refer to https://bugs.debian.org/614907 and https://bugs.debian.org/862051 for details.

Severity: normal, Certainty: possible

Check: scripts, Type: binary

Evolution of the script-uses-deprecated-nodejs-location Lintian tag over the past 366 days:

The beforementioned graph for the script-uses-deprecated-nodejs-location tag

Emitted (non-overridden): 35, overridden: 0, total: 35

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

cleancss 1.0.12-2 (binary)

groovebasin 1.4.0-1 (binary)

jison 0.4.17+dfsg-3 (binary)

libkf5purpose-bin 1.1-5 (binary)

livescript 1.5.0+dfsg-3 (binary)

mocha 1.20.1-7 (binary)

node-ajv 5.0.0-1 (binary)

node-brfs 1.4.3-1 (binary)

node-cpr 2.0.0-2 (binary)

node-dot 1.1.1-1 (binary)

node-escodegen 1.8.1+dfsg-2 (binary)

node-grunt-cli 1.2.0-3 (binary)

node-jison-lex 0.3.4-2 (binary)

node-js-yaml 3.10.0+dfsg-1 (binary)

node-json5 0.5.0-1 (binary)

node-loose-envify 1.3.0+dfsg1-1 (binary)

node-marked-man 0.3.0-1 (binary)

node-mustache 2.3.0-2 (binary)

node-po2json 0.4.5-1 (binary)

node-pre-gyp 0.6.32-1 (binary)

node-quote-stream 1.0.2-3 (binary)

node-rimraf 2.6.2-1 (binary)

node-semver 5.4.1-1 (binary)

node-shelljs 0.7.5-1 (binary)

node-smash 0.0.15-1 (binary)

node-sshpk 1.13.0+dfsg-1 (binary)

node-tape 4.8.0+20172409gitb66f8f80928bb-1 (binary)

node-umd 3.0.1+ds-1 (binary)

nodeunit 0.10.2-1 (binary)

window-size 0.2.0-1 (binary)