Lintian ReportsBETA

Tag versions

Erules-require-build-prerequisite

The tag is present in Lintian version 2.114.68. That is the most recent version we know about.

We use semantic versions. The patch number is a commit step indicator relative to the 2.114.0 release tag in our Git repository.

You can find the detection logic for this version at commit 1af554a. For merge requests, please use the latest version in the Lintian check debian/rules.

Visibility: error

Renamed from:

The code in debian/rules requires a prerequisite that is not presently listed in the package's Build-Depends.

In the special case of Python, affected packages should Build-Depend on one of python3, python3-all, python3-dev, or python3-all-dev. Which one depends on whether a package supports multiple Python versions, and also whether the package builds Python modules or uses Python only as part of the build process.

Packages that depend on a specific Python version may build-depend on any appropriate pythonX.Y or pythonX.Y-dev package instead.

The condition you see in the context is not a recommendation on what to add. If you see a list, more than likely only one member is needed to make this tag go away. You probably also do not need the :any multiarch acceptor, if you see one.

For more information please consult:

The following 8 source packages in the archive triggered the tag 11 times (in any Lintian version).

We found 1 overrides. The tag performed 91% of the time.