Lintian ReportsBETA

Erules-require-build-prerequisite

Tag versions

The tag is present in Lintian version 2.104.319. That is the most recent version we know about.

The code in debian/rules requires the given prerequisite but they are not listed in the package's Build-Depends.

In the special case of Python, affected packages should Build-Depend on one of python3, python3-all, python3-dev, or python3-all-dev. Which one depends on whether a package supports multiple Python versions, and also whether the package builds Python modules or uses Python only as part of the build process.

Packages that depend on a specific Python version may build-depend on any appropriate pythonX.Y or pythonX.Y-dev package instead.

Please refer to Debian Policy Manual section 4.2 for details.

Visibility: error

Check: debian/rules

Renamed from:

The following 9 source packages in the archive triggered the tag 12 times.

We found 1 overrides. The tag performed 92% of the time.