Lintian ReportsBETA

Eruby-script-but-no-ruby-dep

Tag versions

The tag is present in Lintian version 2.109.6. That is the most recent version we know about.

Packages with Ruby scripts must depend on a valid Ruby interpreter. If any script uses #!/usr/bin/ruby, the package should declare ruby as a prerequisite.

In some cases, a weaker relationship like Suggests or Recommends is more appropriate.

Visibility: error

Check: scripts

The following 181 source packages in the archive triggered the tag 464 times.

We found 29 overrides. The tag performed 94% of the time.