Lintian ReportsBETA

Wruby-interpreter-is-deprecated

Tag versions

The tag is present in Lintian version 2.109.24. That is the most recent version we know about.

Starting with ruby2.3, Ruby interpreter packages stopped providing the ruby-interpreter virtual package. It should no longer be used as a prerequisite.

In packages using gem2deb, please consider using ${ruby:Depends}. It will expand automatically to the prerequisites the package needs (including the interpreter as well as the libraries) and can replace all other Ruby-related dependency declarations.

Visibility: warning

Check: languages/ruby

The following 879 source packages in the archive triggered the tag 880 times.

There were no overrides.