Lintian ReportsBETA

Tag versions

Epython3-script-but-no-python3-dep

The tag is present in Lintian version 2.114.55. That is the most recent version we know about.

We use semantic versions. The patch number is a commit step indicator relative to the 2.108.0 release tag in our Git repository.

You can find the detection logic for this version at commit a1e47cb. For merge requests, please use the latest version in the Lintian check scripts.

Visibility: error

Packages with Python3 scripts should depend on the package python3. Those with scripts that specify a specific version of Python3 must depend, recommend or suggest on that version of Python3 (exactly).

For example, if a script in the package uses #!/usr/bin/python3, the package needs a dependency on python3. If a script uses #!/usr/bin/python3.8, the package needs a dependency on python3.8. A dependency on python (>= 3.8) is not correct, since later versions of Python may not provide the /usr/bin/python3.8 binary.

If you are using debhelper, adding ${python3:Depends} to the Depends field and ensuring dh_python3 is run during the build should take care of adding the correct dependency.

In some cases a weaker relationship, such as Suggests or Recommends, will be more appropriate.

The following 26 source packages in the archive triggered the tag 72 times (in any Lintian version).

We found 14 overrides. The tag performed 81% of the time.