Lintian ReportsBETA


Packages with Python2 scripts should depend on the package python2. Those with scripts that specify a specific version of Python2 must depend, recommend or suggest on that version of Python2 (exactly).

For example, if a script in the package uses #!/usr/bin/python2, the package needs a dependency on python2. If a script uses #!/usr/bin/python2.7, the package needs a dependency on python2.7. A dependency on python (>= 2.7) is not correct, since later versions of Python2 may not provide the /usr/bin/python2.7 binary.

If you are using debhelper, adding ${python2:Depends} to the Depends field and ensuring dh_python2 is run during the build should take care of adding the correct dependency.

In some cases a weaker relationship, such as Suggests or Recommends, will be more appropriate.

The tag is present in Lintian version 2.114.163. That is the most recent version we know about.

We use semantic versions. The patch number is a commit step indicator relative to the 2.114.0 release tag in our Git repository.

You can find the detection logic for this version at commit fd97859. For merge requests, please use the latest version in the Lintian check scripts.

Visibility: error

The following 12 source packages in the archive triggered the tag 34 times (in any Lintian version).

There were no overrides.