Lintian ReportsBETA

Wpostinst-uses-db-input

The tag is present in Lintian version 2.104.244. That is the most recent version we know about.

It is generally not a good idea for postinst scripts to use debconf commands like db_input. Typically, they should restrict themselves to db_get to request previously acquired information, and have the config script do the actual prompting.

Visibility: warning

Check: debian/debconf

The following 13 source packages in the archive triggered the tag 13 times.

We found 9 overrides. The tag performed 31% of the time.