Lintian Reports

E possible-gpl-code-linked-with-openssl

All reports of possible-gpl-code-linked-with-openssl for the archive. The extended description of this tag is:

This package appears to be covered by the GNU GPL but depends on the OpenSSL libssl package and does not mention a license exemption or exception for OpenSSL in its copyright file. The GPL (including version 3) is incompatible with some terms of the OpenSSL license, and therefore Debian does not allow GPL-licensed code linked with OpenSSL libraries unless there is a license exception explicitly permitting this.

If only the Debian packaging, or some other part of the package not linked with OpenSSL, is covered by the GNU GPL, please add a Lintian override for this tag. Lintian currently has no good way of distinguishing between that case and problematic packages.

Severity: serious, Certainty: wild-guess

Check: copyright-file, Type: binary

Evolution of the possible-gpl-code-linked-with-openssl Lintian tag over the past 366 days:

The beforementioned graph for the possible-gpl-code-linked-with-openssl tag

Emitted (non-overridden): 20, overridden: 132, total: 152

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

amanda-client 1:3.5.1-1 (binary) overridden

amanda-common 1:3.5.1-1 (binary) overridden

amanda-server 1:3.5.1-1 (binary) overridden

aolserver4-nsopenssl 3.0beta26-6 (binary) overridden

autofdo 0.16-1 (binary) overridden

balsa 2.5.3-4 (binary) overridden

baresip-core 0.5.7-1 (binary) overridden

bip 0.8.9-1.2 (binary) overridden

blogliterately (binary)

coturn (binary) overridden

cyrus-caldav 2.5.10-3+b1 (binary) overridden

cyrus-clients 2.5.10-3+b1 (binary) overridden

cyrus-common 2.5.10-3+b1 (binary) overridden

cyrus-imapd 2.5.10-3+b1 (binary) overridden

cyrus-murder 2.5.10-3+b1 (binary) overridden

dacs 1.4.38a-2+b1 (binary) overridden

dmg2img 1.6.7-1 (binary) overridden

epic5 2.0.1-1+b4 (binary)

gnugk 2:3.6-1+b4 (binary) overridden

hostapd 2:2.6-15 (binary) overridden

ifstat 1.1-8.1+b1 (binary)

ike 2.2.1+dfsg-6 (binary) overridden

ike-qtgui 2.2.1+dfsg-6 (binary) overridden

inn2 2.6.1-4 (binary)

ircii 20170704-1 (binary)

libace-inet-ssl-6.4.5 6.4.5+dfsg-1+b2 (binary) overridden

libace-ssl-6.4.5 6.4.5+dfsg-1+b2 (binary) overridden

libapache2-mod-qos 11.44-1 (binary) overridden

libcyrus-imap-perl 2.5.10-3+b1 (binary) overridden

libdacs1 1.4.38a-2+b1 (binary) overridden

libghc-blogliterately-dev (binary)

libgrpc++1 1.3.2-1 (binary) overridden

libgrpc3 1.3.2-1 (binary) overridden

libopencryptoki0 3.8.1+dfsg-3 (binary) overridden

libpam-ssh 2.1+ds1-2 (binary) overridden

libpion-5.0 5.0.7+dfsg-4 (binary) overridden

libpion-dev 5.0.7+dfsg-4 (binary) overridden

libpion-plugins 5.0.7+dfsg-4 (binary) overridden

libradsec0 0.0.5-4+b1 (binary) overridden

libre0 0.5.7-1 (binary) overridden

librem0 0.5.2-1 (binary) overridden

libsasl2-modules 2.1.27~101-g0780600+dfsg-3 (binary) overridden

libsasl2-modules-gssapi-mit 2.1.27~101-g0780600+dfsg-3 (binary) overridden

libsasl2-modules-otp 2.1.27~101-g0780600+dfsg-3 (binary) overridden

libshairport2 1.2.1~git20120510.cbed0c1-3+b2 (binary) overridden

libtspi1 0.3.14+fixed1-1 (binary) overridden

mailavenger 0.8.4-4.1 (binary) overridden

milter-greylist 4.5.11-1.1+b3 (binary) overridden

open-vm-tools 2:10.2.0-3 (binary)

opencryptoki 3.8.1+dfsg-3 (binary) overridden

pdns-recursor 4.1.1-1 (binary) overridden

perdition 2.2-3+b1 (binary)

petri-foo 0.1.87-4 (binary) overridden

php-http 3.1.0+2.6.0-4+b2 (binary)

picolisp 17.12+20180218-1 (binary) overridden

prayer 1.3.5-dfsg1-4+b1 (binary) overridden

prosody 0.10.0-1 (binary) overridden

pyrit-opencl 0.4.0-1+b2 (binary) overridden

python-scrypt 0.8.0-0.1 (binary) overridden

python3-scrypt 0.8.0-0.1 (binary) overridden

racoon 1:0.8.2+20140711-10 (binary) overridden

radsecproxy 1.6.9-1 (binary) overridden

ruby-eventmachine 1.0.7-4+b1 (binary) overridden

sasl2-bin 2.1.27~101-g0780600+dfsg-3 (binary) overridden

shellinabox 2.20 (binary) overridden

shellinabox 2.20+b1 (binary) overridden

stone 2.3.e-2.1 (binary) overridden

suck 4.3.3-1 (binary) overridden

synergy 1.8.8-stable+dfsg.1-1 (binary) overridden

tnftp 20130505-3+b2 (binary) overridden

tpm2-tools 2.1.0-1 (binary) overridden

trousers 0.3.14+fixed1-1 (binary) overridden

tsdecrypt 10.0-2+b2 (binary) overridden

validns 0.8+git20160720-3 (binary) overridden

weex 2.8.3 (binary)

wpasupplicant 2:2.6-15 (binary) overridden

zfs-fuse 0.7.0-18 (binary) overridden