Lintian Reports

E package-must-activate-ldconfig-trigger

All reports of package-must-activate-ldconfig-trigger for the archive. The extended description of this tag is:

The package installs shared libraries in a directory controlled by the dynamic library loader. Therefore, the package must trigger libc's "ldconfig" trigger to ensure the ldconfig cache is updated.

If the package is using debhelper, dh_makeshlibs should automatically discover this and add the trigger itself. Otherwise, please add activate-noawait ldconfig to the triggers file in the control member.

Note this tag may trigger for packages built with debhelper before version 9.20151004. In such case, a simple rebuild will often be sufficient to fix this issue.

Refer to Debian Policy Manual section 8.1.1 (ldconfig) and https://lists.debian.org/debian-devel/2015/08/msg00412.html for details.

Severity: serious, Certainty: certain

Check: shared-libs, Type: binary, udeb

Evolution of the package-must-activate-ldconfig-trigger Lintian tag over the past 366 days:

The beforementioned graph for the package-must-activate-ldconfig-trigger tag

Emitted (non-overridden): 488, overridden: 61, total: 549

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

blacs1-pvm 1.1-21 (binary)

cervisia 4:16.08.2-1+b1 (binary) overridden

coinor-libcoinmp1v5 1.7.6+dfsg1-2 (binary)

coinor-libdylp0 1.6.0-1.1 (binary)

coinor-libflopc++0 1.0.6-3.1+b2 (binary)

coinor-libvol0 1.1.7-1 (binary)

cvsservice 4:16.08.2-1+b1 (binary) overridden

dirdiff 2.1-7.1 (binary)

duma 2.5.15-1.1+b1 (binary)

electric-fence 2.2.5 (binary)

gdbserver 7.12-6 (binary)

gdbserver 8.0-1 (binary)

ggobi 2.1.11-2 (binary)

guile-cairo 1.4.0-3.1 (binary)

kactivitymanagerd 5.8.4-1 (binary) overridden

kactivitymanagerd 5.8.5-1 (binary) overridden

kcalc 4:16.08.3-1 (binary) overridden

kde-cli-tools 4:5.8.7-1 (binary) overridden

kde-telepathy-text-ui 15.08.3-1+b2 (binary)

kde-telepathy-text-ui 16.04.2-1 (binary) overridden

kded5 5.36.0-2 (binary) overridden

kded5 5.28.0-1 (binary) overridden

kdevelop-php 5.1.1-1 (binary) overridden

kdevelop-python 5.1.1-1 (binary) overridden

khelpcenter 4:16.08.3-1 (binary) overridden

kinit 5.36.0-2 (binary) overridden

kinit 5.28.0-1 (binary) overridden

kmenuedit 4:5.8.5-1 (binary) overridden

kmenuedit 4:5.8.4-1 (binary) overridden

konsole 4:16.12.0-4 (binary) overridden

konsole4-kpart 4:4.14.2-4 (binary) overridden

kpat 4:16.08.1-1+b1 (binary) overridden

kscope 1.9.4-2+b4 (binary)

ksysguard 4:5.8.6-1 (binary) overridden

kup-backup 0.6.1+dfsg-1 (binary) overridden

kwin-x11 4:5.8.7-1 (binary) overridden

lib32cr0 0.8.6~b3-1 (binary)

libamu4 6.2+rc20110530-3.2 (binary)

libasr0 1.0.2-1 (binary)

libattica0.4 0.4.2-2 (binary)

libautounit2 0.20.1-5 (binary)

libax25 0.0.12-rc4-1 (binary)

libbambamc0 0.0.50-1 (binary)

libbase58-0 0.1.4-1 (binary)

libbdd0c2 2.4-11+b1 (binary)

libbiblesync1.1 1.1.2-1 (binary)

libblimps3 3.9-1 (binary)

libblitz0v5 1:0.10-3.3 (binary)

libbulletml0v5 0.0.6-6.1 (binary)

libcaf-core0.13.2 0.13.2-3 (binary)

libcaf-io0.13.2 0.13.2-3 (binary)

libcantor-pythonbackend 4:16.08.3-1 (binary) overridden

libccgnu2-1.8-0v5 1.8.1-6.1 (binary)

libccscript3-1.1-0 1.1.7-2+b1 (binary)

libcddb2 1.3.2-5 (binary)

libcgic2 2.05-3 (binary)

libchardet1 1.0.4-1 (binary)

libchise1 0.3.0-2+b2 (binary)

libckyapplet1 1.1.0-13+b1 (binary)

libclalsadrv2 2.0.0-3+b1 (binary)

libcli1.9 1.9.7-2 (binary)

libclipper2 2.1.20140911-1~exp1 (binary)

libcompfaceg1 1:1.5.2-5+b2 (binary)

libcppcutter0 1.2.4-1 (binary)

libcr0 0.8.6~b3-1 (binary)

libcue1 1.4.0-1 (binary)

libcutter0 1.2.4-1 (binary)

libcvm1 0.96-1.3 (binary)

libcwd 1.0.4-1.1 (binary)

libcxxtools9v5 2.2.1-2 (binary)

libdianewcanvas2 0.6.10-5.4 (binary)

libdiet-admin2.8 2.8.0-1+b3 (binary)

libdiet-client2.8 2.8.0-1+b3 (binary)

libdiet-dagda2.8 2.8.0-1+b3 (binary)

libdiet-sed2.8 2.8.0-1+b3 (binary)

libdiodon0 1.3.0-1 (binary)

libdispatch0 0~svn197-3.3 (binary)

libdistorm64-1 1.7.30-1 (binary)

libdotconf0 1.3-0.2 (binary)

libdssialsacompat0 1.0.8a-1 (binary)

libeditline0 1.12-6.1 (binary)

libee0 0.4.1-1.1 (binary)

libelmersolver-7.0 7.0.svn.6034+dfsg-2 (binary)

libexif-gtk5 0.3.5-5 (binary)

libexo-1-0 0.10.7-1 (binary)

libfap6 1.5-2 (binary)

libfixposix0 20110316.git47f17f7-1 (binary)

libflowcanvas5v5 0.7.1+dfsg0-0.4 (binary)

libflxmlrpc1 0.1.4-1+b1 (binary)

libfsplib0 0.11-2 (binary)

libg15-1 1.2.7-2 (binary)

libg15render1 1.3.0~svn316-2.3 (binary)

libgarmin0 0~svn320-4 (binary)

libgatos0 0.0.5-19 (binary)

libgaviotatb1 0.4-2 (binary)

libgdkcutter-pixbuf0 1.2.4-1 (binary)

libgdome2-0 0.8.1+debian-6 (binary)

libglademm-2.4-1v5 2.6.7-5+b1 (binary)

libglu1-mesa 9.0.0-2.1 (binary)

libgnokii7 0.6.31+dfsg-2+b2 (binary)

libgnomecanvasmm-2.6-1v5 2.26.0-2+b1 (binary)

libgoocanvas-2.0-9 2.0.2-2 (binary)

libgoocanvas3 1.0.0-1 (binary)

libgooglepinyin0 0.1.2-4 (binary)

libgtkgl2.0-1 2.0.1-2.2 (binary)

libgtkspell0 2.0.16-1.1 (binary)

libguytools2 2.0.4-1 (binary)

libhawknl 1.6.8+dfsg2-1 (binary)

libhbaapi2 2.2.9-1 (binary)

libhbalinux2 1.0.16-1 (binary)

libhepmc4 2.06.09-1 (binary)

libhepmcfio4 2.06.09-1 (binary)

libhidapi-hidraw0 0.8.0~rc1+git20140818.d17db57+dfsg-1 (binary)

libhidapi-libusb0 0.8.0~rc1+git20140818.d17db57+dfsg-1 (binary)

libhippocanvas-1-0 0.3.1-1.2 (binary)

libident 0.22-3.1 (binary)

libido-0.1-0 0.3.4-1.1 (binary)

libido3-0.1-0 0.3.4-1.1 (binary)

libinnodb3 1.0.6.6750-1 (binary)

libitl0 0.7.0-3 (binary)

libitsol1 1.0.0-2 (binary)

libjudydebian1 1.0.5-5 (binary)

libjuman4 7.0-3.4 (binary)

libkaz1 1.21-2 (binary)

libkexiv2-11 4:15.04.3-1 (binary)

libkf5purpose-bin 1.1-5 (binary) overridden

libkface3 4:15.04.0-1 (binary)

libkpeople4 0.3.0-2 (binary)

libkpeoplewidgets4 0.3.0-2 (binary)

libkqueue0 2.0.3-1.1 (binary)

libktorrent5 1.3.1-5 (binary)

libkyototycoon2 0.9.56-1+b1 (binary)

libkytea0 0.4.6+dfsg-2 (binary)

liblam4 7.1.4-3.1 (binary)

liblog4c3 1.2.1-3 (binary)

libloki0.1.7 0.1.7-3 (binary)

liblwipv6-2 1.5a-2 (binary)

libm17n-im-config0 0.9.0-3 (binary)

libmadlib 1.3.0-2.1 (binary)

libmaliit-glib0 0.94.1-2 (binary)

libmaliit0 0.94.1-2 (binary)

libmarpa0 6.1.0~dfsg-1 (binary)

libmaxflow0 3.0.4-1 (binary)

libmcrypt4 2.5.8-3.3 (binary)

libmetis-edf4.1 4.1-2-3 (binary)

libmimic0 1.0.4-2.3 (binary)

libmini18n1 0.2.1-1 (binary)

libmm14 1.4.2-5 (binary)

libmmpong0.9 0.9.1-3 (binary)

libmorph 1:20140707+nmu2 (binary)

libmpdclient2 2.9-1 (binary)

libmpeg3-2 1.8.dfsg-2 (binary)

libmsv1 1.1-3 (binary)

libmuparser2v5 2.2.3-6 (binary)

libnet1 1.1.6+dfsg-3 (binary)

libnetclasses0 1.06.dfsg-7 (binary)

libnetfilter-queue1 1.0.2-2 (binary)

libnss-pgsql2 1.4.0debian-8 (binary)

libnss-rainbow2 0.8.7-2 (binary)

libntrack-glib2 016-1.3 (binary)

libntrack-gobject1 016-1.3 (binary)

libntrack-qt4-1 016-1.3 (binary)

libntrack0 016-1.3 (binary)

libnzb0v5 0.0.20050629-6.2 (binary)

liboggplay1 0.2.1~git20091227-2 (binary)

liboglappth2 1.0.0-2 (binary)

libois-1.3.0v5 1.3.0+dfsg0-6 (binary)

libopenms2.0 2.0.0-4+b3 (binary)

libpcre++0v5 0.9.5-6.1 (binary)

libperformance0.5 0.5.0-1 (binary)

libphp7.0-embed 7.0.22-3 (binary)

libphp7.1-embed 7.1.8-1 (binary)

libpolyclipping16 6.1.3a-2 (binary)

libpoti4 4.2-1 (binary)

libpqtypes0 1.5.1-2 (binary)

libpri1.4 1.4.15-1 (binary)

libprintsys 0.6-13 (binary)

libpthread-workqueue0 0.9.1-1 (binary)

libpurelibc1 0.4.1-1 (binary)

libqinfinity3 1:0.5.1-1 (binary)

libqmf1 0.16-9 (binary)

libqmf2-1 0.16-9 (binary)

libqmfconsole2 0.16-9 (binary)

libqmfengine1 0.16-9 (binary)

libqoauth1 1.0.1-2 (binary)

libqpidbroker2 0.16-9 (binary)

libqpidclient2 0.16-9 (binary)

libqpidcommon2 0.16-9 (binary)

libqpidmessaging2 0.16-9 (binary)

libqpidtypes1 0.16-9 (binary)

libqtexengine1 0.3-3 (binary)

libqwt5-qt4 5.2.3-1 (binary)

libqxmlrpc1 0.0.svn6-2 (binary)

libraul10 0.8.0+dfsg0-0.1+b1 (binary)

librcc0 0.2.12-0.1 (binary)

librccgtk2-0 0.2.12-0.1 (binary)

librcd0 0.1.13-3 (binary)

librdmawrap2 0.16-9 (binary)

libregina3 3.6-2.1 (binary)

libresample1 0.1.3-4 (binary)

librlog5v5 1.4-4 (binary)

libroboptim-core2 2.0-7.1 (binary)

librsskit0d 0.4-1 (binary)

librsync2 1.0.0-1~exp1 (binary)

libsafe-iop0 0.3.1-1 (binary)

libscalc0v5 0.2.4-4.1 (binary)

libserial0 0.6.0~rc2+svn122-4 (binary)

libsfark0 2.24-1 (binary)

libshhmsg1 1.4.2-1 (binary)

libshhopt1 1.1.7-3 (binary)

libsidl-1.4.0 1.4.0.dfsg-8.2 (binary)

libsigx-2.0-2 2.0.2-5+b1 (binary)

libsnl0 0.2.1.svn.18-1 (binary)

libsnmpkit2c2a 0.9-16 (binary)

libsoil1 1.07~20080707.dfsg-2 (binary)

libsoupcutter0 1.2.4-1 (binary)

libsparskit2.0 2.0.0-2 (binary)

libspctag1 0.2-1 (binary)

libspnav0 0.2.3-1 (binary)

libsqlclient1.8 1.8.1-1 (binary)

libsslcommon2 0.16-9 (binary)

libsss-sudo 1.15.3-1 (binary)

libst1 1.9-3.1 (binary)

libswiften2 2.0+dev6-1+b1 (binary)

libsynopsis0.12v5 0.12-10 (binary)

libtcd0 2.2.2-2 (binary)

libthrift-0.9.2 0.9.2-2 (binary)

libthrift-c-glib0 0.9.2-2 (binary)

libtinysvm1 0.09+dfsg-2 (binary)

libtogl1 1.7-12 (binary)

libtpl0 1.6.1-1 (binary)

libtriangle-1.6 1.6-2 (binary)

libudt0 4.11+dfsg1-1 (binary)

libuhttpmock-0.0-0 0.5.0-1 (binary)

libunibreak1 1.1-2 (binary)

libunicap2 0.9.12-2 (binary)

libusb-java-lib 0.8+ztex20090101-7 (binary)

libusbtc08-1 1.7.2-5 (binary)

libvanessa-adt1 0.0.9-2 (binary)

libvanessa-logger0 0.0.10-3+b2 (binary)

libvanessa-socket2 0.0.13-1+b2 (binary)

libvcdinfo0 0.7.24+dfsg-0.2 (binary)

libvdk2-2c2 2.4.0-5.4 (binary)

libview2 0.6.6-2.1+b2 (binary)

libvolpack1 1.0b3-5 (binary)

libvulkan-dev 1.0.54.0+dfsg1-1 (binary)

libvw0 7.3-1.1+b2 (binary)

libwnn6-1 1.0.0-18 (binary)

libxdg-basedir1 1.2.0-1 (binary)

libxfce4ui-1-0 4.12.1-2 (binary)

libxfce4ui-2-0 4.12.1-2 (binary)

libxmpi4 2.2.3b8-13.2 (binary)

libxnee0 3.19-1 (binary)

libxsettings0 0.11-4 (binary)

libyamcha1 0.33-1 (binary)

libyaml-cpp0.3v5 0.3.0-1.2 (binary)

libydpdict2 1.0.4-3 (binary)

libygl4 4.2e-4 (binary)

lldpad 0.9.46-3.1 (binary)

lua-apr 0.23.2.dfsg-4 (binary)

lua-cjson 2.1.0+dfsg-2 (binary)

lua-filesystem 1.6.3-1 (binary)

lua-lpty 1.0.1-1 (binary)

lua-md5 1.2+git+1+8d87fee-1 (binary)

lua-svn 0.4.0-9 (binary)

lua-wsapi-fcgi 1.6.1-1 (binary)

lua-zip 1.2.3-12 (binary)

maildir-utils 0.9.18-2 (binary)

maliit-framework 0.94.1-2 (binary)

marble-plugins 4:16.08.3-1 (binary) overridden

mono-runtime-common 4.6.2.7+dfsg-1 (binary)

plasma-desktop 4:5.8.7.1-1 (binary) overridden

plasma-nm 4:5.8.6-1 (binary) overridden

plasma-pa 4:5.8.7-1 (binary) overridden

plasma-workspace 4:5.8.7-1 (binary) overridden

print-manager 4:16.08.3-1 (binary) overridden

python-vmtk 1.3+dfsg-2.2 (binary)

rviz 1.12.4+dfsg-2+b1 (binary)

sgb 1:20090810-1 (binary)

slop 6.3.47-1 (binary)

smp-utils 0.98-1 (binary)

xaw3dg 1.5+E-18.2 (binary)

xviewg 3.2p1.4-28.2 (binary)