Lintian Reports

I package-contains-no-arch-dependent-files

All reports of package-contains-no-arch-dependent-files for the archive. The extended description of this tag is:

The package is not marked architecture all, but all the files it ships are installed in /usr/share.

Most likely this package should be marked architecture all, but there is a chance that the package is missing files.

Refer to Debian Policy Manual section 5.6.8 (Architecture) for details.

Severity: minor, Certainty: possible

Check: files, Type: binary, udeb

This tag is marked experimental, which means that the code that generates it is not as well-tested as the rest of Lintian and might still give surprising results. Feel free to ignore experimental tags that do not seem to make sense, though of course bug reports are always welcome.

Evolution of the package-contains-no-arch-dependent-files Lintian tag over the past 366 days:

The beforementioned graph for the package-contains-no-arch-dependent-files tag

Emitted (non-overridden): 282, overridden: 12, total: 294

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

astrometry-data-tycho2-07 2-3 (binary)


astrometry-data-tycho2-08 2-3 (binary)


astrometry-data-tycho2-09 2-3 (binary)


astrometry-data-tycho2-10-19 2-3 (binary)


blimps-examples 3.9-1 (binary)


build-essential 12.3 (binary)


cl-clx-sbcl 0.7.4.20160323-1 (binary)


clang-3.8-examples 1:3.8.1-23 (binary)


clang-3.9-examples 1:3.9.1-8 (binary)


clang-4.0-examples 1:4.0.1~+rc1-1 (binary)


clang-5.0-examples 1:5.0~svn301421-1 (binary)


code-saturne 4.3.3+repack-1 (binary)


cpp-for-host 4.9.2-1~exp3 (binary)


cpp-i586-linux-gnu 4.9.2-1~exp3 (binary)


cpp-x86-64-linux-gnu 4.9.2-1~exp3 (binary)


debian-installer 20170525 (binary)


debram 2.0.0.5 (binary)


dolphin-dev 4:16.08.3-3 (binary)


e17-dbg 0.17.6-1.1+b1 (binary)


empathy-skype 20140930+svn665+dfsg-1 (binary)


extra-cmake-modules 5.28.0-1 (binary)


g++-for-host 4.9.2-1~exp3 (binary)


g++-i586-linux-gnu 4.9.2-1~exp3 (binary)


g++-x86-64-linux-gnu 4.9.2-1~exp3 (binary)


gambas3-templates 3.9.1-3 (binary)


gcc-5-test-results 5.4.1-11 (binary)


gcc-6-test-results 6.3.0-18 (binary)


gcc-7-test-results 7.1.0-6 (binary)


gcc-for-host 4.9.2-1~exp3 (binary)


gcc-i586-linux-gnu 4.9.2-1~exp3 (binary)


gcc-x86-64-linux-gnu 4.9.2-1~exp3 (binary)


gfortran-for-host 4.9.2-1~exp3 (binary)


gfortran-i586-linux-gnu 4.9.2-1~exp3 (binary)


gfortran-x86-64-linux-gnu 4.9.2-1~exp3 (binary)


ghc-testsuite 8.0.1-1 (binary)


gnome-shell-extension-show-ip 4.0.1-1 (binary)


gnome-speech-dectalk 1:0.4.25-6+b1 (binary)


gnome-speech-ibmtts 1:0.4.25-6+b1 (binary)


gnome-speech-swift 1:0.4.25-6+b1 (binary)


gnumach-image-1-486 2:1.8+git20170102-1 (binary)


gnumach-image-1-xen-486 2:1.8+git20170102-1 (binary)


golang-1.7-src 1.7.4-2 (binary)


golang-1.8-src 1.8.1-1 (binary)


golang-github-prometheus-alertmanager-dev 0.5.1+ds-7+b2 (binary)


golang-vhost-dev 0.0~git20140120-1 (binary)


grub-firmware-qemu 2.02~beta3-5 (binary)


grub-theme-starfield 2.02~beta3-5 (binary)


haskell-misfortune 0.1.1.2-5+b2 (binary)


isc-dhcp-common 4.3.5-3 (binary)


kalgebra-common 4:16.08.3-1 (binary)


kicad-common 4.0.5+dfsg1-4 (binary) overridden


kwin-addons 4:5.8.5-2 (binary)


libadminutil-data 1.1.23-1 (binary)


libatteanx-endpoint-perl 0.001-3 (binary)


libatteanx-store-sparql-perl 0.010-1 (binary)


libbitcoin0v5 2.11.0-1+b1 (binary)


libbitcoin0v5-dbg 2.11.0-1+b1 (binary)


libbluetooth3-dbg 5.43-2 (binary)


libbrowserlauncher-java 1.3+dfsg-1 (binary)


libcanary-stability-perl 2006-1 (binary)


libdevice-usb-pcsensor-hidtemper-perl 2:0.04-1 (binary)


libemos-data 2:4.4.5-2 (binary)


libemos-data 2:4.4.7-1 (binary)


libexo-helpers 0.10.7-1 (binary)


libgnome2-0 2.32.1-5+b1 (binary)


libgtk2.0-bin 2.24.31-2 (binary)


libhamlib2-tcl 3.0.1-1+b1 (binary)


libhdf5-mpi-dev 1.10.0-patch1+docs-3 (binary)


libhmsbeagle-java 2.1.2+20160831-5 (binary)


libjhdf4-java 2.11.0+dfsg-2+b1 (binary)


libjhdf5-java 2.11.0+dfsg-2+b1 (binary)


libkf5kipi-bin 4:16.08.2-1 (binary) overridden


libkmlframework-java 0.0.20110822.r24-2 (binary)


liblld-4.0-dbg 1:4.0.1~+rc1-1 (binary)


liblld-5.0-dbg 1:5.0~svn301421-1 (binary)


libluajit-5.1-common 2.1.0~beta2+dfsg-3 (binary)


libmamajni-java 2.2.2.1-11.1 (binary)


libmamda-book-java 2.2.2.1-11.1 (binary)


libmamda-java 2.2.2.1-11.1 (binary)


libmamda-options-java 2.2.2.1-11.1 (binary)


libngs-java 1.3.0-2 (binary)


libopenni-java 1.5.4.0-14+b1 (binary)


libpcp-logsummary-perl 3.11.10 (binary)


libphone-ui-shr-data 0.1+git20130901-3 (binary)


libphp-predis 0.8.3-1 (binary)


libproj-java 4.9.3-2~exp1 (binary)


libproj-java 4.9.3-1 (binary)


libqt4-dbus 4:4.8.7+dfsg-11 (binary)


librime-data-array30 0.35-1 (binary)


librime-data-bopomofo 0.35-1 (binary)


librime-data-cangjie5 0.35-1 (binary)


librime-data-combo-pinyin 0.35-1 (binary)


librime-data-double-pinyin 0.35-1 (binary)


librime-data-emoji 0.35-1 (binary)


librime-data-ipa-xsampa 0.35-1 (binary)


librime-data-jyutping 0.35-1 (binary)


librime-data-luna-pinyin 0.35-1 (binary)


librime-data-pinyin-simp 0.35-1 (binary)


librime-data-quick5 0.35-1 (binary)


librime-data-sampheng 0.35-1 (binary)


librime-data-scj6 0.35-1 (binary)


librime-data-soutzoe 0.35-1 (binary)


librime-data-stenotype 0.35-1 (binary)


librime-data-stroke 0.35-1 (binary)


librime-data-terra-pinyin 0.35-1 (binary)


librime-data-wubi 0.35-1 (binary)


librime-data-wugniu 0.35-1 (binary)


librime-data-zyenpheng 0.35-1 (binary)


libsane-extras-common 1.0.22.4 (binary)


libsundials-serial 2.5.0-3+b3 (binary)


libsys-syscall-perl 0.25-6 (binary)


libwebsocketpp-dev 0.7.0-8 (binary)


libz3-java 4.4.1-0.3 (binary)


libzmq-java 3.1.0-10 (binary)


lightdm-vala 1.18.3-2 (binary)


ltsp-client 5.5.9-2 (binary)


lua-sandbox-extensions 0~git20161128-1 (binary)


lua-sandbox-extensions-dev 0~git20161128-1 (binary)


lua-torch-graph 0~20161027-g47afe90-2 (binary) overridden


lua-uri 0.1+20130926+git14fa255d-1 (binary)


lua-uri-dev 0.1+20130926+git14fa255d-1 (binary)


midisnoop 0.1.2~repack0-5+b2 (binary)


mpi-testsuite 3.2+dfsg-1 (binary)


netgen-headers 4.9.13.dfsg-8+b4 (binary)


nvidia-egl-common 375.39-1 (binary) overridden


nvidia-legacy-check 375.39-1 (binary) overridden


nvidia-vulkan-common 375.39-1 (binary) overridden


openturns-examples 1.7-3 (binary)


percona-xtrabackup-test 2.2.3-2.1 (binary)


phonon-backend-gstreamer-common 4:4.9.0-1 (binary)


phonon-backend-null 4:4.9.0-4 (binary)


phonon4qt5-backend-null 4:4.9.0-4 (binary)


php-nrk-predis 1.0.0-1 (binary)


pidgin-skype 20140930+svn665+dfsg-1 (binary)


plasma-theme-oxygen 4:5.8.5-1 (binary)


plasma-theme-oxygen 4:5.8.4-1 (binary)


plasma-wallpapers-addons 4:5.8.5-2 (binary)


plume-creator-dbg 0.66+dfsg1-3.1+b2 (binary)


posixtestsuite 1.5.2-6 (binary)


primus-libs-ia32 0~20150328-4 (binary)


ros-tf2-msgs 0.5.13-5 (binary)


sddm-theme-breeze 4:5.8.6-2 (binary)


sddm-theme-debian-breeze 4:5.8.6-2 (binary)


sigrok-firmware-fx2lafw 0.1.3-1 (binary)


sipwitch-cgi 1.9.15-3+b1 (binary)


slepc-dev 3.7.3+dfsg1-5 (binary)


slurmdbd-dbg 16.05.9-1 (binary)


swi-prolog 7.2.3+dfsg-6 (binary)


tarantool-lts-modules 1.5.5.37.g1687c02-1 (binary)


tbb-examples 4.3~20150611-2 (binary)


trilinos-all-dev 12.10.1-3 (binary)


wims-java-applets 1:4.13c~dfsg1-2 (binary)


wreport-common 3.6-1 (binary)


xserver-xorg 1:7.7+19 (binary)


z88dk 1.8.ds1-10 (binary)