Lintian Reports

E not-binnmuable-any-depends-all

The package is not safely binNMUable because an arch:any package depends on an arch:all package with a (= ${binary:Version}) relationship. Please use (= ${source:Version}) instead.

Note this is also triggered if the dependency uses (>= ${var}), since that has the same issue.

Visibility: error

Check: debian/version-substvars

These source packages in the archive trigger the tag.