Lintian Reports (Beta Testing)

E not-binnmuable-all-depends-any

The package is not safely binNMUable because an arch:all package depends on an arch:any package with a strict (= ${source:Version}), or similar, relationship.

It is not possible for arch:all packages to depend so strictly on arch:any packages while having the package binNMUable, so please use one of these, whichever is more appropriate:

Depends: arch_any (>= ${source:Version}) Depends: arch_any (>= ${source:Version}), arch_any (<< ${source:Version}.1~)

Severity: error

Check: debian/version-substvars

These source packages in the archive trigger the tag.