Lintian Reports

W new-package-should-not-package-python2-module

All reports of new-package-should-not-package-python2-module for the archive. The extended description of this tag is:

This package appears to be the initial packaging of a new upstream software package (ie. it contains a single changelog entry). However, it ships the specified module for Python 2.

Python 2.x modules should not be packaged unless strictly necessary (such as being explicitly requested by an end-user or required as part of a dependency chain) as the 2.x series of Python is due for deprecation and will not be maintained by upstream past 2020 and will likely be dropped after the release of Debian "buster".

If upstream have not moved or have no intention to move to Python 3, please be certain that Debian would benefit from the inclusion, continued maintenance burden and (eventual) removal of this package before you upload.

This warning can be ignored if the package is not intended for Debian or if it is a split of an existing Debian package. This warning can also be ignored if viewed on https://lintian.debian.org/.

Please do not override this warning; rather, add a justification to your changelog entry; Lintian looks in this version's changelog entry for the specified package name or the phrase "Python 2 version" or similar.

Severity: normal, Certainty: certain

Check: python, Type: source, binary

Evolution of the new-package-should-not-package-python2-module Lintian tag over the past 366 days:

The beforementioned graph for the new-package-should-not-package-python2-module tag

Emitted (non-overridden): 182, overridden: 18, total: 200

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

python-aiodns 1.1.1-1 (binary)

python-antlr3 3.5.2-1 (binary)

python-aws-requests-auth 0.4.1-1 (binary) overridden

python-aws-xray-sdk 0.95-1 (binary)

python-awsauth 0.1.5-1 (binary)

python-azure-devtools 0.5.0+git-1 (binary)

python-azure-storage 0.33.0-1 (binary)

python-backup2swift 0.8-1 (binary)

python-bdist-nsi 0.1.5-1 (binary) overridden

python-bitbucket 0.1-1 (binary)

python-bitcoin 1.1.42-1 (binary)

python-btrees 4.3.1-1+b2 (binary)

python-bunch 1.0.1-1 (binary)

python-bz2file 0.98-1 (binary)

python-caldav 0.4.0-1 (binary)

python-cdiff 1.0-1 (binary)

python-cgcloud-core 1.6.0-1 (binary)

python-cgcloud-lib 1.6.0-1 (binary)

python-chartkick 0.5.0-1 (binary)

python-codegen 1.0-1 (binary)

python-codicefiscale 0.9+ds0-1 (binary)

python-colour 0.1.5-1 (binary)

python-commonmark-bkrs 0.5.4+ds-1 (binary)

python-constantly 15.1.0-1 (binary)

python-cookies 2.2.1-1 (binary)

python-datrie 0.7.1-1+b1 (binary)

python-dcmstack 0.6.2+git33-gb43919a.1-1 (binary)

python-dicttoxml 1.7.4-1 (binary)

python-django-fsm-admin 1.2.1-1 (binary)

python-django-html-sanitizer 0.1.5-1 (binary)

python-django-maintenancemode 0.11.2-1 (binary)

python-django-overextends 0.4.0-1 (binary)

python-django-ranged-response 0.2.0-1 (binary)

python-django-redis-admin 1.4.0-1 (binary)

python-dnslib 0.9.7+hg20170303-1 (binary)

python-doubleratchet 0.3.1-1 (binary) overridden

python-dracclient 1.3.1-1 (binary)

python-ebooklib 0.15~ds0-1 (binary)

python-editorconfig 0.12.1-1 (binary)

python-envparse 0.2.0-1 (binary) overridden

python-epc 0.0.5-1 (binary) overridden

python-etcd3gw 0.2.1-1 (binary)

python-exotel 0.1.5-1 (binary) overridden

python-fakesleep 0.1-1 (binary)

python-fcgi 19980130-1 (binary)

python-fftw 0.2.2-1 (binary)

python-flask-api 0.6.4+dfsg-1 (binary)

python-flask-bcrypt 0.7.1-1 (binary)

python-flask-flatpages 0.6-1 (binary)

python-flask-gravatar 0.4.2-1 (binary)

python-flask-peewee 0.6.7-1 (binary)

python-flask-principal 0.4.0-1 (binary)

python-flask-sockets 0.2.1-1 (binary)

python-flask-testing 0.4.2-1 (binary)

python-flaskext.multistatic 1.0-1 (binary)

python-fmcs 1.0-1 (binary)

python-fontconfig 0.5.1-1+b6 (binary)

python-fontconfig-dbg 0.5.1-1+b6 (binary)

python-frozendict 0.5-1 (binary)

python-fte 0.1.0-1 (binary)

python-fusepy 2.0.4-1 (binary)

python-gcm-client 0.1.4-1 (binary)

python-genty 1.3.0-1 (binary)

python-gpyfft 0.7.0-1+b1 (binary)

python-gpyfft-dbg 0.7.0-1+b1 (binary)

python-gtextfsm 0.2.1-1 (binary)

python-gtts 1.2.0-1 (binary)

python-gtts-token 1.1.1-1 (binary)

python-haproxy-log-analysis 2.0~b0-1 (binary)

python-hdf-compass 0.6.0-1 (binary)

python-httmock 1.2.6-1 (binary)

python-hydroffice.bag 0.2.15-1 (binary)

python-ilorest 2.3.1+20180725+ds-1 (binary)

python-inflection 0.3.1-1 (binary)

python-isbnlib 3.5.6-1 (binary)

python-iso3166 0.8.git20170319-1 (binary)

python-json-tricks 3.11.0-1 (binary)

python-jsonext 0.4.1-1 (binary)

python-k8sclient 0.3.0-1 (binary)

python-kdl-parser 1.13.0-1 (binary)

python-keepalive 0.5-1 (binary)

python-krbv 1.0.90-1 (binary)

python-lazyarray 0.1.0-1 (binary)

python-libguess 1.1-1 (binary)

python-libmapper 0.3~git+20141027-1+b1 (binary)

python-libthumbor 1.3.2-1 (binary)

python-logging-tree 1.4-1 (binary)

python-logsparser 0.4-1 (binary)

python-loofah 0.1-1 (binary)

python-mimerender 0.6.0-1 (binary)

python-mk-livestatus 0.2-1 (binary)

python-mmllib 0.3.0.post1-1 (binary) overridden

python-monasca-statsd 1.7.0-1 (binary)

python-morris 1.2-1 (binary)

python-multi-key-dict 2.0.3-1 (binary)

python-nb2plots 0.6-1 (binary)

python-networking-ovs-dpdk 2015.1.1+git20151118.35ac4c7-1 (binary)

python-nose-random 1.0.0-1 (binary)

python-nototools 0~20170925-1 (binary)

python-numpysane 0.15-1 (binary)

python-offtrac 0.1.0-1 (binary)

python-olm 2.2.2+git20170526.0fd768e+dfsg-1 (binary)

python-opencv-apps 1.11.14-1 (binary)

python-os-net-config 0.1.0-1 (binary)

python-pager 3.3-1 (binary)

python-paho-mqtt 1.3.1-1 (binary)

python-paisley 0.3.1-1 (binary)

python-park 1.0.0-1 (binary)

python-pdfkit 0.5.0-1 (binary)

python-pexif 0.15-1 (binary)

python-phpserialize 1.3-1 (binary)

python-priority 1.3.0-1 (binary)

python-progress 1.2-1 (binary)

python-psycogreen 1.0-1 (binary)

python-pydispatch 2.0.5-1 (binary)

python-pyee 3.0.3-1 (binary) overridden

python-pyeos 0.63-1 (binary)

python-pyethash 0.1.27-1+b1 (binary)

python-pygerrit2 2.0.4-1 (binary)

python-pygtail 0.6.1-1 (binary)

python-pyknon 1.0-1 (binary)

python-pynwb 0.5.1-1 (binary)

python-pypuppetdb 0.1.1+git080614-1 (binary)

python-pyqrcode 1.2.1-1 (binary)

python-pyramid-multiauth 0.8.0-1 (binary)

python-pysmi 0.2.2-1 (binary) overridden

python-pyssim 0.2-1 (binary)

python-pyst 0.6.50-1 (binary)

python-pyte 0.4.8-1 (binary)

python-pytest-bdd 2.18.2-1 (binary)

python-pytest-expect 1.1.0-1 (binary)

python-pytest-pep8 1.0.6-1 (binary)

python-pytest-sourceorder 0.5-1 (binary)

python-pytoml 0.1.2-1 (binary)

python-pyxenstore 0.0.2-1 (binary)

python-randomize 0.14-1 (binary)

python-rawkit 0.6.0-1 (binary)

python-rcssmin 1.0.6-1+b3 (binary)

python-rediscluster 1.3.3-1 (binary)

python-ricky 0.1-1 (binary)

python-rlp 0.5.1-1 (binary)

python-robot-detection 0.4.0-1 (binary)

python-rstr 2.2.6-1 (binary)

python-rudolf 0.3-1 (binary)

python-scales 1.0.9-1 (binary)

python-schedule 0.3.2-1 (binary)

python-sdl2 0.9.3+dfsg2-1 (binary)

python-sdnotify 0.3.1-1 (binary)

python-sexpdata 0.0.3-1 (binary) overridden

python-sgp4 1.4-1 (binary)

python-snowballstemmer 1.2.1-1 (binary)

python-sphinxcontrib.rubydomain 0.1~dev-20100804-1 (binary)

python-sphinxcontrib.youtube 1.0-1 (binary)

python-sphinxtesters 0.1.1-1 (binary)

python-staticconf 0.10.3-1 (binary) overridden

python-stomp 4.1.19-1 (binary) overridden

python-stopit 1.1.1-1 (binary)

python-swiftsc 0.5-1 (binary)

python-test-server 0.0.27-1 (binary) overridden

python-testing.common.database 2.0.0-1 (binary)

python-testing.postgresql 1.3.0-1 (binary)

python-tinycss 0.4-1+b4 (binary)

python-tinycss 0.4-1+b3 (binary)

python-tinyrpc 0.6-1 (binary)

python-tornadorpc 0.1.1-1 (binary)

python-translitcodec 0.3-1 (binary)

python-treq 15.1.0-1 (binary)

python-trie 0.2+ds-1 (binary)

python-tvrage 0.4.1-1 (binary)

python-twilio 6.8.2-1 (binary) overridden

python-twodict 1.2-1 (binary)

python-u-msgpack 2.1-1 (binary)

python-uinput 0.11.2-1 (binary) overridden

python-unipath 0.2.1+dfsg-1 (binary)

python-urwidtrees 1.0.1.1-1 (binary)

python-vispy 0.4.0-1 (binary)

python-vsgui 0.3.3-1 (binary)

python-wchartype 0.1-1 (binary)

python-wsaccel 0.6.2-1+b1 (binary)

python-xeddsa 0.3.6-1 (binary) overridden

python-xmlbuilder 1.0-1 (binary)

python-zc.customdoctests 1.0.1-1 (binary)

python-zodbpickle 1.0-1+b1 (binary)