Lintian Reports

W needless-dependency-on-jre

All reports of needless-dependency-on-jre for the archive. The extended description of this tag is:

The package appear to be a Java library and depending on one or more JRE/JDK packages. As of 05 Apr 2010, the Java Policy no longer mandates that Java libraries depend on Java Runtimes.

If the library package ships executables along with the library, then please consider making this an application package or move the binaries to a (new) application package.

If there is otherwise a valid reason for this dependency, please override the tag.

Refer to https://lists.debian.org/debian-devel-changes/2010/04/msg00774.html and https://bugs.debian.org/227587 for details.

Severity: normal, Certainty: possible

Check: fields, Type: binary, udeb, source

Evolution of the needless-dependency-on-jre Lintian tag over the past 366 days:

The beforementioned graph for the needless-dependency-on-jre tag

Emitted (non-overridden): 17, overridden: 1, total: 18

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

libbytecode-java 0.92.svn.20090106-2 (binary)


libconcurrent-java 1.3.4-4 (binary)


libemma-java 2.0.5312+dfsg-4 (binary)


libezmorph-java 1.0.6-3 (binary)


libgeronimo-ejb-3.0-spec-java 1.0.1-1 (binary)


libgeronimo-jms-1.1-spec-java 1.1-1.2 (binary)


libgeronimo-jpa-3.0-spec-java 1.1.1-1 (binary)


libjboss-serialization-java 1.0.3.GA+dak1-3 (binary)


libjdbm-java 1.0-2 (binary)


libjunitperf-java 1.9.1-8 (binary)


libnetx-java 0.5-2 (binary)


libopsin-java 1.5.0-1 (binary)


libow-util-ant-tasks-java 1.3.2-4 (binary)


libsidl1.4.0-java 1.4.0.dfsg-8.2 (binary)


libsikulixapi-java 1.1.0-2 (binary) overridden


libsimple-xml-java 2.7.1-1 (binary)


libtrove-java 2.1.0-2 (binary)


libzemberek-java 2.1.1-8.2 (binary)