Lintian Reports (Beta Testing)

E missing-dependency-on-phpapi

This package includes a *.so file in /usr/lib/phpN (where N is a number representing the major PHP version), normally indicating that it includes a PHP extension. PHP extensions must depend on phpapi-$(php-configN --phpapi), without adding an alternative package with the OR operator.

This can usually be achieved by, for example, adding the following code to the binary-arch target of the rules file and adding ${php:Depends} to the Depends field of the binary package shipping the extension:

echo "php:Depends=phpapi-$(php-config5 --phpapi)" > debian/substvars

Severity: error

Check: binaries

These source packages in the archive trigger the tag.