Lintian ReportsBETA

Emissing-build-dependency

The tag is present in Lintian version 2.104.244. That is the most recent version we know about.

The package doesn't specify a build dependency on a package that is used in debian/rules.

Lintian intentionally does not take into account transitive dependencies. Even if the package build-depends on some package that in turn depends on the needed package, an explicit build dependency should be added. Otherwise, a latent bug is created that will appear without warning if the other package is ever updated to change its dependencies. Even if this seems unlikely, please always add explicit build dependencies on every non-essential, non-build-essential package that is used directly during the build.

Refer to Debian Policy Manual section 4.2 for details.

Visibility: error

Check: debian/rules

Found no packages in the archive that triggered the tag.