Lintian ReportsBETA

Wmaintscript-calls-ldconfig

Tag versions

The tag is present in Lintian version 2.104.318. That is the most recent version we know about.

The given maintainer script calls ldconfig. However, explicit calls in maintainer scripts should be replaced by a dpkg trigger.

Please replace the "ldconfig" call with an activate-noawait ldconfig trigger. With debhelper it is usually sufficient to simply add that line to debian/<package>.triggers.

If you use debhelper, this warning will appear if the package was compiled with debhelper before 9.20151004. Assuming all ldconfig invocations have been added by debhelper, this warning will disappear once the package is rebuilt with a newer version of debhelper.

Please refer to https://lists.debian.org/debian-devel/2015/08/msg00412.html for details.

Visibility: warning

Check: shared-libs

The following 53 source packages in the archive triggered the tag 79 times.

The tag was masked 2 times through screens.

We found 6 overrides. The tag performed 92% of the time.