Lintian Reports

W maintainer-script-should-not-use-update-alternatives-remove

All reports of maintainer-script-should-not-use-update-alternatives-remove for the archive. The extended description of this tag is:

update-alternatives --remove <alternative> foo is called in the postrm. This can be dangerous because at the time the postrm is executed foo has already been deleted and update-alternatives will ignore it while constructing its list of available alternatives. Then, if the /etc/alternatives symlink points at foo, update-alternatives won't recognize it and will mark the symlink as something site-specific. As such, the symlink will no longer be updated automatically and will be left dangling until update-alternatives --auto <alternative> is run by hand.

update-alternatives --remove should be called in the prerm instead.

Refer to Debian Policy Manual appendix F (Alternative versions of an interface - update-alternatives (from old Packaging Manual)) and the update-alternatives(8) manual page for details.

Severity: normal, Certainty: certain

Check: scripts, Type: binary

Evolution of the maintainer-script-should-not-use-update-alternatives-remove Lintian tag over the past 366 days:

The beforementioned graph for the maintainer-script-should-not-use-update-alternatives-remove tag

Emitted (non-overridden): 282, overridden: 5, total: 287

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

acpica-tools 20160831-1+b1 (binary)

miwm 1.1-6 (binary) overridden

mysql-common 5.8+1.0.2 (binary) overridden

puppet-module-adrienthebo-filemapper 1.1.3-1 (binary)

puppet-module-aodh 9.4.0-1 (binary)

puppet-module-camptocamp-kmod 2.1.1-1 (binary)

puppet-module-camptocamp-openssl 1.5.0-1 (binary)

puppet-module-ceilometer 9.4.0-1 (binary)

puppet-module-cinder 9.4.0-1 (binary)

puppet-module-duritong-sysctl 0.0.11-1 (binary)

puppet-module-glance 9.4.0-1 (binary)

puppet-module-heat 9.4.0-1 (binary)

puppet-module-horizon 9.4.0-1 (binary)

puppet-module-ironic 9.4.0-1 (binary)

puppet-module-keystone 9.4.0-1 (binary)

puppet-module-manila 9.4.0-1 (binary)

puppet-module-michaeltchapman-galera 0.0.3-2 (binary)

puppet-module-murano 9.4.0-1 (binary)

puppet-module-nanliu-staging 1.0.4-1 (binary)

puppet-module-neutron 9.4.0-1 (binary)

puppet-module-nova 9.4.0-1 (binary)

puppet-module-openstacklib 9.4.0-1 (binary)

puppet-module-oslo 9.4.0-1 (binary)

puppet-module-puppet-community-mcollective 0.6.2-2 (binary)

puppet-module-puppetlabs-mongodb 0.7.0-2 (binary)

puppet-module-puppetlabs-rabbitmq 5.3.1-2 (binary)

puppet-module-puppetlabs-rsync 0.2.0-2 (binary)

puppet-module-puppetlabs-tftp 0.2.3-2 (binary)

puppet-module-puppetlabs-vcsrepo 1.3.2-1 (binary)

puppet-module-richardc-datacat 0.6.2-1 (binary)

puppet-module-sahara 9.4.0-1 (binary)

puppet-module-saz-rsyslog 2.2.1-1 (binary)

puppet-module-saz-ssh 2.8.1-2 (binary)

puppet-module-sbitio-monit 1.0.0-2 (binary)

puppet-module-swift 9.4.4-1 (binary)

puppet-module-vswitch 5.4.0-1 (binary)

python-alembic 0.8.8-2 (binary)

python-aodhclient 0.7.0-2 (binary)

python-bandit 1.1.0-3 (binary)

python-barbicanclient 4.0.1-2 (binary)

python-bashate 0.3.1-2 (binary)

python-ceilometerclient 2.6.2-1 (binary)

python-cinderclient 1:1.9.0-3 (binary)

python-designateclient 2.3.0-2 (binary)

python-dib-utils 0.0.6-1 (binary)

python-doc8 0.6.0-4 (binary)

python-falcon 1.0.0-2 (binary)

python-gabbi 1.24.0-2 (binary)

python-gear 0.5.8-3 (binary)

python-gflags 1.5.1-2 (binary)

python-git-os-job 1.0.1-1 (binary)

python-glance-store 0.18.0-2 (binary)

python-glanceclient 1:2.5.0-3 (binary)

python-gnocchiclient 2.2.0-4 (binary)

python-heatclient 1.4.0-2 (binary)

python-invoke 0.11.1+dfsg1-1 (binary)

python-ironicclient 1.7.1-1 (binary)

python-jenkins-job-builder 1.6.1-1 (binary)

python-json-pointer 1.10-1 (binary)

python-jsonpatch 1.19-4 (binary)

python-jsonpath-rw 1.4.0-2 (binary)

python-jsonschema 2.5.1-6 (binary)

python-lesscpy 0.10-1 (binary)

python-magnumclient 2.3.1-1 (binary)

python-manilaclient 1.11.0-2 (binary)

python-migrate 0.10.0-7 (binary)

python-misaka 1.0.2-5+b1 (binary)

python-mistralclient 1:2.1.2-1 (binary)

python-monascaclient 1.2.0-2 (binary)

python-muranoclient 0.11.1-1 (binary)

python-neutron-vpnaas 2:9.0.0-3 (binary)

python-neutronclient 1:6.0.0-2 (binary)

python-novaclient 2:6.0.0-2 (binary)

python-openstack-doc-tools 0.34.0-2 (binary)

python-openstackclient 3.2.1-1 (binary)

python-os-testr 0.7.0-2 (binary)

python-oslo.concurrency 3.14.0-2 (binary)

python-oslo.config 1:3.17.0-3 (binary)

python-oslo.messaging 5.10.0-2 (binary)

python-oslo.policy 1.14.0-2 (binary)

python-oslo.privsep 1.13.0-2 (binary)

python-oslo.rootwrap 5.1.0-2 (binary)

python-oslotest 1:2.10.0-2 (binary)

python-osprofiler 1.4.0-2 (binary)

python-pbr 1.10.0-1 (binary)

python-pecan 1.1.2-3 (binary)

python-protorpc-standalone 0.9.1-3 (binary)

python-pulp 1.6.0+dfsg1-1 (binary)

python-pykmip 0.5.0-4 (binary)

python-pysaml2 3.0.0-5 (binary)

python-q-text-as-data 1.4.0-1 (binary)

python-qrcode 5.3-1 (binary)

python-reno 1.3.0-6 (binary)

python-restructuredtext-lint 0.12.2-2 (binary)

python-rtslib-fb 2.1.57+debian-4 (binary)

python-saharaclient 0.18.0-2 (binary)

python-senlinclient 1.0.0-3 (binary)

python-swiftclient 1:3.1.0-3 (binary)

python-tackerclient 0.7.0-2 (binary)

python-tempest 1:12.2.0-1 (binary)

python-tempest-lib 0.14.0-3 (binary)

python-testrepository 0.0.20-2 (binary) overridden

python-troveclient 1:2.5.0-2 (binary)

python-unittest2 1.1.0-6.1 (binary)

python-watcherclient 0.25.1-1 (binary)

python-websocket 0.37.0-2 (binary)

python-yaql 1.1.1-2 (binary)

python3-alembic 0.8.8-2 (binary)

python3-aodhclient 0.7.0-2 (binary)

python3-bandit 1.1.0-3 (binary)

python3-barbicanclient 4.0.1-2 (binary)

python3-bashate 0.3.1-2 (binary)

python3-ceilometerclient 2.6.2-1 (binary)

python3-cinderclient 1:1.9.0-3 (binary)

python3-designateclient 2.3.0-2 (binary)

python3-dib-utils 0.0.6-1 (binary)

python3-doc8 0.6.0-4 (binary)

python3-falcon 1.0.0-2 (binary)

python3-gabbi 1.24.0-2 (binary)

python3-gear 0.5.8-3 (binary)

python3-gflags 1.5.1-2 (binary)

python3-git-os-job 1.0.1-1 (binary)

python3-glance-store 0.18.0-2 (binary)

python3-glanceclient 1:2.5.0-3 (binary)

python3-gnocchiclient 2.2.0-4 (binary)

python3-heatclient 1.4.0-2 (binary)

python3-invoke 0.11.1+dfsg1-1 (binary)

python3-ironicclient 1.7.1-1 (binary)

python3-jenkins-job-builder 1.6.1-1 (binary)

python3-json-pointer 1.10-1 (binary)

python3-jsonpatch 1.19-4 (binary)

python3-jsonpath-rw 1.4.0-2 (binary)

python3-jsonschema 2.5.1-6 (binary)

python3-lesscpy 0.10-1 (binary)

python3-magnumclient 2.3.1-1 (binary)

python3-manilaclient 1.11.0-2 (binary)

python3-migrate 0.10.0-7 (binary)

python3-misaka 1.0.2-5+b1 (binary)

python3-mistralclient 1:2.1.2-1 (binary)

python3-monascaclient 1.2.0-2 (binary)

python3-muranoclient 0.11.1-1 (binary)

python3-neutronclient 1:6.0.0-2 (binary)

python3-novaclient 2:6.0.0-2 (binary)

python3-openstack-doc-tools 0.34.0-2 (binary)

python3-openstackclient 3.2.1-1 (binary)

python3-os-testr 0.7.0-2 (binary)

python3-oslo.concurrency 3.14.0-2 (binary)

python3-oslo.config 1:3.17.0-3 (binary)

python3-oslo.messaging 5.10.0-2 (binary)

python3-oslo.policy 1.14.0-2 (binary)

python3-oslo.privsep 1.13.0-2 (binary)

python3-oslo.rootwrap 5.1.0-2 (binary)

python3-oslotest 1:2.10.0-2 (binary)

python3-osprofiler 1.4.0-2 (binary)

python3-pbr 1.10.0-1 (binary)

python3-pecan 1.1.2-3 (binary)

python3-protorpc-standalone 0.9.1-3 (binary)

python3-pulp 1.6.0+dfsg1-1 (binary)

python3-pykmip 0.5.0-4 (binary)

python3-pysaml2 3.0.0-5 (binary)

python3-q-text-as-data 1.4.0-1 (binary)

python3-qrcode 5.3-1 (binary)

python3-reno 1.3.0-6 (binary)

python3-restructuredtext-lint 0.12.2-2 (binary)

python3-rtslib-fb 2.1.57+debian-4 (binary)

python3-saharaclient 0.18.0-2 (binary)

python3-senlinclient 1.0.0-3 (binary)

python3-swiftclient 1:3.1.0-3 (binary)

python3-tackerclient 0.7.0-2 (binary)

python3-tempest 1:12.2.0-1 (binary)

python3-tempest-lib 0.14.0-3 (binary)

python3-testrepository 0.0.20-2 (binary) overridden

python3-troveclient 1:2.5.0-2 (binary)

python3-unittest2 1.1.0-6.1 (binary)

python3-watcherclient 0.25.1-1 (binary)

python3-websocket 0.37.0-2 (binary)

python3-yaql 1.1.1-2 (binary)

skytools3 3.2.6-5+b1 (binary)

skytools3-walmgr 3.2.6-5+b1 (binary)

tsdecrypt 10.0-2+b2 (binary)

xfce4-session 4.12.1-5 (binary)