Lintian Reports

E maintainer-script-should-not-use-service

All reports of maintainer-script-should-not-use-service for the archive. The extended description of this tag is:

The maintainer script apparently runs the service command. This command is reserved for local administrators and must never be used by a Debian package.

Please replace with calls to update-rc.d(8) and invoke-rc.d(8). If your package installs this service, this can be automated using dh_installinit(1) or dh_installsystemd(1).

Refer to Debian Policy Manual section 9.3.3 (Interfacing with init systems) for details.

Severity: important, Certainty: certain

Check: scripts, Type: binary

This tag is marked experimental, which means that the code that generates it is not as well-tested as the rest of Lintian and might still give surprising results. Feel free to ignore experimental tags that do not seem to make sense, though of course bug reports are always welcome.

Evolution of the maintainer-script-should-not-use-service Lintian tag over the past 366 days:

The beforementioned graph for the maintainer-script-should-not-use-service tag

Emitted (non-overridden): 140, overridden: 2, total: 142

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

389-ds-base 1.3.8.2-1 (binary)

chemical-structures 2.2.dfsg.0-13 (binary)

diaspora-common 0.7.4.0 (binary)

diaspora-installer 0.7.4.0 (binary)

dms-core 1.0.8.1-1 (binary)

dms-core 1.0.8-1.2 (binary)

dtc-xen-firewall 0.5.17-1.2 (binary)

erlang-base 1:20.3.8.1+dfsg-1 (binary)

erlang-base 1:21.0.2+dfsg-1~exp1 (binary)

erlang-base-hipe 1:20.3.8.1+dfsg-1 (binary)

erlang-base-hipe 1:21.0.2+dfsg-1~exp1 (binary)

evqueue-core 2.0-1+b1 (binary)

expeyes-web 4.4.3+dfsg-1 (binary)

ez-ipupdate 3.0.11b8-13.4.1 (binary)

gitlab 10.7.5+dfsg-2 (binary)

gitlab 10.6.5+dfsg-2 (binary)

gitlab-runner 11.0.0+dfsg-2 (binary) overridden

ldap-account-manager 6.3-1 (binary)

libc6 2.27-4 (binary)

libpam0g 1.1.8-3.7 (binary)

libssl1.0.2 1.0.2o-1 (binary)

libssl1.1 1.1.0h-4 (binary)

libssl1.1 1.1.1~~pre8-1 (binary)

nslcd 0.9.9-1 (binary)

pynslcd 0.9.9-1 (binary)

python-expeyes 4.4.3+dfsg-1 (binary)

sopel 6.5.3-1 (binary)

sysv-rc 2.88dsf-59.10 (binary)

ufw 0.35-6 (binary)

wims 1:4.15d~dfsg1-1 (binary)