Lintian ReportsBETA

E maintainer-script-does-not-check-for-existence-of-installdocs

The maintainer script calls the install-docs command without checking that it exists, but the doc-base package, which provides the command, is not an essential package and may not be available.

For example, you can use the following code in your maintainer script:

if which install-docs > /dev/null; then
     install-docs -i /usr/share/doc-base/<your-package>
fi

The tag is present in Lintian version 2.114.140. That is the most recent version we know about.

We use semantic versions. The patch number is a commit step indicator relative to the 2.114.0 release tag in our Git repository.

You can find the detection logic for this version at commit 23f836f. For merge requests, please use the latest version in the Lintian check menus.

Visibility: error

The following 1 source packages in the archive triggered the tag 1 times (in any Lintian version).

There were no overrides.