Lintian ReportsBETA

Ilinked-with-obsolete-library

The tag is present in Lintian version 2.104.244. That is the most recent version we know about.

This tag is currently only issued for libcblas.so. For an explanation, please continue below.

The symbols in libcblas.so, which represent the CBLAS API, were merged into libblas.so. (Note the missing letter C.) Please use libblas.so instead.

The old library is still being shipped until all packages have modified their build systems, but it is not managed by update-alternatives and may result in poor performance. Please do not use it anymore.

Some packages may require functionality specific to Atlas3, which is not implemented by other BLAS/CBLAS alternatives. Please override the tag if your package falls into that category.

Refer to https://wiki.debian.org/DebianScience/LinearAlgebraLibraries, https://lists.debian.org/debian-devel/2019/10/msg00273.html, and https://salsa.debian.org/science-team/lapack/-/blob/master/debian/README.if-you-look-for-libcblas.so.3 for details.

Visibility: info

Check: libraries/shared/obsolete

The following 4 source packages in the archive triggered the tag 4 times.

There were no overrides.