Lintian Reports

W init.d-script-possible-missing-stop

All reports of init.d-script-possible-missing-stop for the archive. The extended description of this tag is:

The given /etc/init.d script indicates it should be stopped at one of the runlevels 0, 1, or 6 but not at all of them. This is usually a mistake. Normally, facilities that need to be stopped at any of those runlevels need to be stopped at all of them.

For example, if it is safe for the facility provided by this init script to be stopped by sendsigs at runlevels 0 and 6, there should be no reason to special case runlevel 1, where killprocs would stop it. If the facility needs special shutdown handling when rebooting the system (runlevel 6), it probably needs the same handling when halting the system (runlevel 0) or switching to single-user mode (runlevel 1).

Severity: normal, Certainty: possible

Check: init.d, Type: binary

Evolution of the init.d-script-possible-missing-stop Lintian tag over the past 366 days:

The beforementioned graph for the init.d-script-possible-missing-stop tag

Emitted (non-overridden): 26, overridden: 41, total: 67

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

acpi-support 0.142-8 (binary) overridden

aoetools 36-2 (binary)

apmd 3.2.2-15+b2 (binary)

arno-iptables-firewall 2.0.1.f-1 (binary) overridden

cipux-rpcd 3.4.0.9-3.1 (binary)

controlaula 1.8.0-3.1 (binary)

cryptsetup 2:1.7.3-4 (binary) overridden

cups-daemon 2.2.4-3 (binary) overridden

dictd 1.12.1+dfsg-4 (binary) overridden

digitools 1.03-1.2 (binary)

esekeyd 1.2.7-1+b2 (binary)

ifscheme 1.7-5 (binary) overridden

ifupdown 0.8.24 (binary) overridden

initscripts 2.88dsf-59.9 (binary) overridden

kexec-tools 1:2.0.14-1 (binary) overridden

live-tools 1:20151214+nmu1 (binary)

ltsp-client-core 5.5.9-2 (binary) overridden

ltsp-controlaula 1.8.0-3.1 (binary)

mdadm 4.0-1 (binary)

nbd-client 1:3.15.2-3 (binary)

nbd-client 1:3.16.1-1 (binary)

netscript-2.4 5.5.2 (binary) overridden

netscript-ipfilter 5.5.2 (binary) overridden

nis 3.17.1-1+b1 (binary)

plymouth 0.9.2-4 (binary) overridden

portreserve 0.0.4-1+b2 (binary)

pptpd 1.4.0-10 (binary) overridden

quota 4.03-3 (binary) overridden

resolvconf 1.79 (binary) overridden

scanlogd 2.2.5-3.3 (binary)

smartmontools 6.5+svn4324-1 (binary)

ufw 0.35-5 (binary) overridden

unattended-upgrades 0.94 (binary)

util-linux 2.29.2-4 (binary) overridden

zfs-fuse 0.7.0-17 (binary) overridden