Lintian Reports

E init.d-script-missing-dependency-on-remote_fs

All reports of init.d-script-missing-dependency-on-remote_fs for the archive. The extended description of this tag is:

The given init script seems to refer to /usr, possibly using a file or binary from there. Without a dependency on $remote_fs in Required-Start or Required-Stop, as appropriate, the init script might be run before /usr is mounted or after it's unmounted.

Using Should-Start or Should-Stop to declare the dependency is conceptually incorrect since the $remote_fs facility is always available. Required-Start or Required-Stop should be used instead. Also, please note that $all should not be used in Required-Stop, only Required-Start.

Refer to https://wiki.debian.org/LSBInitScripts for details.

Severity: important, Certainty: possible

Check: init.d, Type: binary

Evolution of the init.d-script-missing-dependency-on-remote_fs Lintian tag over the past 366 days:

The beforementioned graph for the init.d-script-missing-dependency-on-remote_fs tag

Emitted (non-overridden): 46, overridden: 52, total: 98

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

apparmor 2.11.0-3 (binary) overridden

aptitude-robot 1.5.1-1 (binary) overridden

auditd 1:2.6.7-2 (binary) overridden

bluemon 1.4-6.1+b1 (binary)

bootlogd 2.88dsf-59.9 (binary) overridden

bwbar 1.2.3-2.1+b2 (binary)

captagent 6.1.0.20-3 (binary)

certmaster 0.25-1.1 (binary)

dhis-server 5.3-2.1+b2 (binary)

downtimed 1.0-1 (binary) overridden

g15daemon 1.9.5.3-8.3+b1 (binary)

initscripts 2.88dsf-59.9 (binary) overridden

kmod 24-1 (binary)

lpr 1:2008.05.17.2+b1 (binary)

ltsp-client-core 5.5.9-2 (binary) overridden

mdadm 3.4-4+b1 (binary)

minisapserver 0.3.6-1.1+b3 (binary)

nbd-client 1:3.15.2-3 (binary) overridden

netscript-2.4 5.5.1 (binary) overridden

netscript-ipfilter 5.5.1 (binary) overridden

nfs-common 1:1.3.4-2.1 (binary) overridden

pglistener 4 (binary) overridden

powerman 2.3.5-1+b2 (binary)

pppconfig 2.3.23 (binary) overridden

racoon 1:0.8.2+20140711-8 (binary) overridden

shorewall-init 5.0.15.6-1 (binary) overridden

yubikey-server-c 0.5-1+b4 (binary)

zemberek-server 0.7.1-12.2 (binary)