Lintian ReportsBETA

Eillegal-variable

Tag versions

The tag is present in Lintian version 2.104.234. That is the most recent version we know about.

With debhelper compatibility level >= 13 (and also dh-exec before it) several files in the ./debian folder support the expansion of variables. Unfortunately, people sometimes confuse the DEB_BUILD_* variables with the similarly-named DEB_HOST_* variables.

Some conditions are difficult to detect but it is never correct to use DEB_BUILD_MULTIARCH in debian/*.install or in debian/*.links.

Please use DEB_HOST_MULTIARCH instead of DEB_BUILD_MULTIARCH.

Refer to https://wiki.debian.org/Multiarch/Implementation#Recipes_for_converting_packages and Bug#983219 for details.

Visibility: error

Check: debian/variables

The following 1 source packages in the archive triggered the tag 1 times.

There were no overrides.