Lintian ReportsBETA

Wgir-missing-typelib-dependency

Tag versions

The tag is present in Lintian version 2.104.328. That is the most recent version we know about.

Development packages that contain GObject-Introspection XML files (/usr/share/gir-1.0/Foo-23.gir) must depend on the package containing the corresponding binary typelib, which is conventionally named gir1.2-foo-23. The dependency must be strictly versioned (for example gir1.2-foo-23 (= ${binary:Version}) when using debhelper).

If multiple typelibs are shipped in the same package, then that package should have versioned Provides for the names that would have been used for separate packages. In this case, Lintian does not emit this tag when a group of binary packages from the same source is checked together.

For example, libgtk-3-dev contains Gtk-3.0.gir, Gdk-3.0.gir and GdkX11-3.0.gir. gir1.2-gtk-3.0 contains all three corresponding typelibs, so it is sufficient for libgtk-3-dev to depend on gir1.2-gtk-3.0. Giving gir1.2-gtk-3.0 Provides entries for gir1.2-gdk-3.0 (= ${binary:Version}) and gir1.2-gdkx11-3.0 (= ${binary:Version}) signals this situation to Lintian.

Please refer to /usr/share/doc/gobject-introspection/policy.txt for details.

Visibility: warning

Check: desktop/gnome/gir

The following 28 source packages in the archive triggered the tag 62 times.

We found 6 overrides. The tag performed 90% of the time.