Lintian Reports

W gir-missing-typelib-dependency

All reports of gir-missing-typelib-dependency for the archive. The extended description of this tag is:

Development packages that contain GObject-Introspection XML files (/usr/share/gir-1.0/Foo-23.gir) must depend on the package containing the corresponding binary typelib, which is conventionally named gir1.2-foo-23. The dependency must be strictly versioned (for example gir1.2-foo-23 (= ${binary:Version}) when using debhelper).

If multiple typelibs are shipped in the same package, then that package should have versioned Provides for the names that would have been used for separate packages. In this case, Lintian does not emit this tag when a group of binary packages from the same source is checked together.

For example, libgtk-3-dev contains Gtk-3.0.gir, Gdk-3.0.gir and GdkX11-3.0.gir. gir1.2-gtk-3.0 contains all three corresponding typelibs, so it is sufficient for libgtk-3-dev to depend on gir1.2-gtk-3.0. Giving gir1.2-gtk-3.0 Provides entries for gir1.2-gdk-3.0 (= ${binary:Version}) and gir1.2-gdkx11-3.0 (= ${binary:Version}) signals this situation to Lintian.

Refer to /usr/share/doc/gobject-introspection/policy.txt for details.

Severity: normal, Certainty: possible

Check: gir, Type: binary, source

Evolution of the gir-missing-typelib-dependency Lintian tag over the past 366 days:

The beforementioned graph for the gir-missing-typelib-dependency tag

Emitted (non-overridden): 147, overridden: 32, total: 179

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

gir1.2-entangle-0.1 0.7.2-1 (binary)

gir1.2-gnumeric 1.12.41-1 (binary)

gir1.2-lunar-date-2.0 2.4.0-4 (binary)

gir1.2-wnck-1.0 2.30.7-5.1 (binary)

gnome-maps 3.28.2-1 (binary)

ibus-anthy-dev 1.5.9-3 (binary)

libaccounts-glib-dev 1.23-1 (binary)

libavahi-gobject-dev 0.7-4 (binary) overridden

libburner-media3-dev 3.0.6-1 (binary) overridden

libcinnamon-desktop-dev 3.8.1-2 (binary)

libclutter-gst-3.0-dev 3.0.26-1 (binary)

libcogl-dev 1.22.2-3 (binary)

libcogl-pango-dev 1.22.2-3 (binary)

libcolord-dev 1.3.3-2 (binary)

libcolorhug-dev 1.3.3-2 (binary)

libcscreensaver0 3.8.2-1 (binary)

libdbusmenu-glib-dev 16.04.1+18.04.20171206-1 (binary)

libdbusmenu-gtk-dev 16.04.1+18.04.20171206-1 (binary)

libdbusmenu-gtk3-dev 16.04.1+18.04.20171206-1 (binary)

libdee-dev 1.0.10-3.2+b1 (binary)

libfarstream-0.2-dev 0.2.8-4 (binary)

libfolks-dev 0.11.4-1+b2 (binary)

libganv-dev 1.4.2~dfsg0-2 (binary)

libges-1.0-dev 1.14.2-1 (binary)

libgirepository1.0-dev 1.56.1-1 (binary)

libgirepository1.0-dev 1.57.2-2 (binary)

libgrilo-0.3-dev 0.3.6-1 (binary) overridden

libgrss-dev 0.7.0-2 (binary)

libgstreamer-plugins-bad1.0-dev 1.14.2-1 (binary)

libgstreamer-plugins-base1.0-dev 1.14.2-1 (binary)

libgstreamer1.0-dev 1.14.2-2 (binary)

libgstrtspserver-1.0-dev 1.14.2-1 (binary)

libgtk-4-dev 3.91.2-1 (binary)

libgtk-vnc-2.0-dev 0.7.2-1 (binary)

libgtkspell3-3-dev 3.0.9-2 (binary)

libgupnp-av-1.0-dev 0.12.10-1 (binary)

libgupnp-dlna-2.0-dev 0.10.5-3+b1 (binary)

libgusb-dev 0.2.11-1 (binary)

libgvnc-1.0-dev 0.7.2-1 (binary)

libinput-pad-dev 1.0.3-1+b1 (binary)

libisocodes-dev 1.2.2-2 (binary)

libjavascriptcoregtk-1.0-dev 2.4.11-4 (binary) overridden

libjavascriptcoregtk-3.0-dev 2.4.11-4 (binary) overridden

libjavascriptcoregtk-4.0-dev 2.20.5-1 (binary) overridden

libjavascriptcoregtk-4.0-dev 2.21.5-1 (binary) overridden

liblimba-dev 0.5.6-2+b2 (binary)

libmuffin-dev 3.8.2-1 (binary)

libnm-glib-dev 1.10.6-2 (binary) overridden

librest-extras-dev 0.8.0-2 (binary)

libsignon-glib-dev 1.12-2 (binary)

libsoup-gnome2.4-dev 2.62.2-2 (binary)

libsugarext-dev 0.112-2 (binary)

libuhttpmock-dev 0.5.0-1 (binary)

libvirt-glib-1.0-dev 1.0.0-1 (binary)

libvirt-sandbox-1.0-dev 0.5.1+git20160404-1 (binary)

libwebkit2gtk-4.0-dev 2.20.5-1 (binary) overridden

libwebkit2gtk-4.0-dev 2.21.5-1 (binary) overridden

libwebkitgtk-dev 2.4.11-4 (binary) overridden

pitivi 0.99-3 (binary)

pluma-dev 1.20.2-1 (binary)

v-sim 3.7.2-5+b1 (binary)

workrave-data 1.10.20-1 (binary)