Lintian Reports

W excessive-priority-for-library-package

All reports of excessive-priority-for-library-package for the archive. The extended description of this tag is:

The given package appears to be a library package, but it has "Priority" of "required", "important", or "standard".

In general, a library package should only get pulled in on a system because some other package depends on it; no library package needs installation on a system where nothing uses it.

Please update debian/control and downgrade the severity to, for example, Priority: optional.

Severity: normal, Certainty: possible

Check: fields, Type: binary, udeb, source

Evolution of the excessive-priority-for-library-package Lintian tag over the past 366 days:

The beforementioned graph for the excessive-priority-for-library-package tag

Emitted (non-overridden): 66, overridden: 0, total: 66

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

libacl1 2.2.52-3+b1 (binary)

libattr1 1:2.4.47-2+b2 (binary)

libbz2-1.0 1.0.6-9 (binary)

libcap2 1:2.25-1.2 (binary)

libdb5.3 5.3.28+dfsg1-0.2 (binary)

libedit2 3.1-20180525-1 (binary)

libevent-2.0-5 2.0.21-stable-3 (binary)

libevent-2.1-6 2.1.8-stable-4 (binary)

libgc1c2 1:7.6.4-0.4 (binary)

libgcc1 1:8.2.0-8 (binary)

libgnutls-openssl27 3.5.19-1+b1 (binary)

libgnutls30 3.5.19-1+b1 (binary)

libgssglue1 0.4-2+b2 (binary)

libident 0.22-3.1 (binary)

libkeyutils1 1.5.9-9.3 (binary)

liblockfile1 1.14-1.1 (binary)

liblzma5 5.2.2-1.3 (binary)

libmnl-dev 1.0.4-2 (binary)

libmnl0 1.0.4-2 (binary)

libnfsidmap2 0.25-5.1 (binary)

libpci3 1:3.5.2-1 (binary)

libpcre3 2:8.39-11 (binary)

libpipeline1 1.5.0-1 (binary)

libreadline7 7.0-5 (binary)

libreadline8 8.0~alpha1-1 (binary)

librpcsecgss3 0.19-7+b2 (binary)

libsasl2-2 2.1.27~rc8-1 (binary)

libsasl2-modules-db 2.1.27~rc8-1 (binary)

libssl1.0.2 1.0.2o-1 (binary)

libstdc++6 8.2.0-8 (binary)

libsysfs2 2.1.0+repack-4+b2 (binary)

libtasn1-6 4.13-3 (binary)

libtirpc1 0.2.5-1.3 (binary)

libwrap0 7.6.q-27 (binary)