Lintian Reports

W doc-package-depends-on-main-package

All reports of doc-package-depends-on-main-package for the archive. The extended description of this tag is:

The name of this package suggests that it is a documentation package. It is usually not desirable for documentation packages to depend on the packages they document, because users may want to install the docs before they decide whether they want to install the package. Also, documentation packages are often architecture-independent, so on other architectures the package on which it depends may not even exist.

Severity: normal, Certainty: possible

Check: fields, Type: binary, udeb, source

Evolution of the doc-package-depends-on-main-package Lintian tag over the past 366 days:

The beforementioned graph for the doc-package-depends-on-main-package tag

Emitted (non-overridden): 10, overridden: 3, total: 13

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

keepass2-doc 2.37+dfsg-1 (binary)

libfannj-java-doc 0.3-1 (binary)

libjs-extjs-doc 3.4.0+dfsg1-1 (binary) overridden

libjsr311-api-java-doc 1.1.1-1 (binary)

libjtharness-java-doc 5.0-1 (binary)

mdk-doc 1.2.9-3 (binary) overridden

monotone-doc 1.1-9 (binary)

multiboot-doc 0.97-72 (binary)

perl-doc 5.26.1-2 (binary) overridden

pmw-doc 1:4.29-2 (binary)

python-gtk2-doc 2.24.0-5.1 (binary)

python-quixote-doc 2.7~b2-1.1 (binary)

screenlets-doc 0.1.2-8.1 (binary)