Lintian ReportsBETA

Wdoc-package-depends-on-main-package

Tag versions

The tag is present in Lintian version 2.104.234. That is the most recent version we know about.

The name of this package suggests that it is a documentation package. It is usually not desirable for documentation packages to depend on the packages they document, because users may want to install the docs before they decide whether they want to install the package. Also, documentation packages are often architecture-independent, so on other architectures the package on which it depends may not even exist.

Visibility: warning

Check: fields/package-relations

The following 6 source packages in the archive triggered the tag 6 times.

We found 2 overrides. The tag performed 67% of the time.