Lintian ReportsBETA

Wdistant-prerequisite-in-shlibs

Tag versions

The tag is present in Lintian version 2.109.3. That is the most recent version we know about.

This package declares in its shlibs control file either a dependency on some other package not listed in the Provides of this package or on a version of this package that the package version doesn't satisfy.

Packages should normally only list in their shlibs control file the shared libraries included in that package, and therefore the dependencies listed there should normally be satisfied by either the package itself or one of its Provides.

In unusual circumstances where it's necessary to declare more complex dependencies in the shlibs control file, please add a Lintian override for this warning.

Please refer to Debian Policy Manual section 8.6 for details.

Visibility: warning

Check: debian/shlibs

Renamed from:

The following 18 source packages in the archive triggered the tag 837 times.

We found 834 overrides. The tag performed 0% of the time.