Lintian Reports

W dev-pkg-without-shlib-symlink

All reports of dev-pkg-without-shlib-symlink for the archive. The extended description of this tag is:

A "-dev" package is supposed to install a "libsomething.so" symbolic link referencing the corresponding shared library. Notice how the link name doesn't include the version number -- this is because such a link is used by the linker when other programs are built against this shared library.

The symlink is generally expected in the same directory as the library itself. The major exception to this rule is if the library is installed in (or beneath) /lib, where the symlink must be installed in the same dir beneath /usr.

Example: If the library is installed in /lib/i386-linux-gnu/libXYZ.so.V, the symlink is expected at /usr/lib/i386-linux-gnu/libXYZ.so.

Implementation detail: This tag is emitted for the library package and not the "-dev" package.

Refer to Debian Policy Manual section 8.4 (Development files) for details.

Severity: normal, Certainty: certain

Check: shared-libs, Type: binary, udeb

Evolution of the dev-pkg-without-shlib-symlink Lintian tag over the past 366 days:

The beforementioned graph for the dev-pkg-without-shlib-symlink tag

Emitted (non-overridden): 229, overridden: 235, total: 464

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

binutils-multiarch 2.30-20 (binary) overridden

binutils-multiarch 2.30.51.20180512-1 (binary) overridden

gammaray 2.9.0-2 (binary)

kded5 5.46.0-1 (binary) overridden

kinit 5.46.0-1 (binary) overridden

kwin-common 4:5.12.5-1 (binary) overridden

lib++dfb-1.7-7 1.7.7-8 (binary) overridden

libabiword-3.0 3.0.2-6+b1 (binary) overridden

libacl1 2.2.52-3+b1 (binary)

libadplug-2.2.1-0v5 2.2.1+dfsg3-0.4 (binary)

libatm1 1:2.5.1-2 (binary)

libattr1 1:2.4.47-2+b2 (binary)

libball1.4 1.4.3~beta1-3+b1 (binary)

libball1.4 1.4.3~beta1-4 (binary)

libballview1.4 1.4.3~beta1-3+b1 (binary)

libballview1.4 1.4.3~beta1-4 (binary)

libbinutils 2.30-20 (binary) overridden

libbinutils 2.30.51.20180512-1 (binary) overridden

libblasr 0~20161219-2 (binary)

libc6 2.27-3 (binary)

libccgnu2-1.8-0v5 1.8.1-6.1 (binary)

libcg 3.1.0013-4 (binary) overridden

libcggl 3.1.0013-4 (binary) overridden

libclips 6.30-4+b1 (binary)

libdirectfb-1.7-7 1.7.7-8 (binary) overridden

libdistorm64-1 1.7.30-1 (binary)

libdsdp-5.8gf 5.8-9.4 (binary)

libeinfo1 0.34-2 (binary)

libelektra4 0.8.14-5.1 (binary)

libevent-2.1-6 2.1.8-stable-4 (binary)

libevent-core-2.1-6 2.1.8-stable-4 (binary)

libevent-extra-2.1-6 2.1.8-stable-4 (binary)

libevent-openssl-2.1-6 2.1.8-stable-4 (binary)

libevent-pthreads-2.1-6 2.1.8-stable-4 (binary)

libf2fs0 1.10.0-1 (binary)

libfaifa0 0.2~svn82-1+b2 (binary)

libganglia1 3.6.0-7+b2 (binary)

libgegl-0.4-0 0.4.2-1 (binary)

libglobus-common0 17.4-1 (binary) overridden

libglobus-xio-gridftp-driver 2.17-2 (binary) overridden

libglobus-xio-gridftp-multicast 1.7-2 (binary) overridden

libglobus-xio-gsi-driver 4.1-1 (binary) overridden

libglobus-xio-net-manager-driver 0.18-1 (binary) overridden

libglobus-xio-pipe-driver 3.10-2 (binary) overridden

libglobus-xio-popen-driver 3.6-2 (binary) overridden

libglobus-xio-rate-driver 1.8-2 (binary) overridden

libglobus-xio-udt-driver 1.29-1 (binary) overridden

libgraphicsmagick++-q16-12 1.3.29-1 (binary)

libgraphicsmagick-q16-3 1.3.29-1 (binary)

libgtextutils0v5 0.7-4 (binary) overridden

libgtkdatabox-0.9.3-0 1:0.9.3.0+dfsg-3 (binary) overridden

libguichan-0.8.1-1v5 0.8.2-18 (binary) overridden

libguichan-allegro-0.8.1-1v5 0.8.2-18 (binary) overridden

libguichan-opengl-0.8.1-1v5 0.8.2-18 (binary) overridden

libguichan-sdl-0.8.1-1v5 0.8.2-18 (binary) overridden

libguvcview-2.0-2 2.0.5+debian-1 (binary)

libhmsbeagle1v5 2.1.2+git20180307-1 (binary)

libib-util 3.0.3.32900.ds4-3+b1 (binary) overridden

libid3-3.8.3v5 3.8.3-16.2+b1 (binary)

libilmbase23 2.2.1-2 (binary)

libimage-transport0d 1.11.11-3 (binary)

libkf5balooengine5 5.46.0-1 (binary)

libkf5globalaccelprivate5 5.46.0-1 (binary) overridden

libkf5purpose-bin 5.46.0-1 (binary) overridden

libladr4 0.0.200911a-2.1+b2 (binary)

liblavfile-2.1-0 1:2.1.0+debian-5 (binary)

liblavjpeg-2.1-0 1:2.1.0+debian-5 (binary)

liblavplay-2.1-0 1:2.1.0+debian-5 (binary)

libldap-2.4-2 2.4.46+dfsg-5 (binary) overridden

liblorene-debian1 0.0.0~cvs20161116+dfsg-1+b1 (binary)

liblorene-export-debian0 0.0.0~cvs20161116+dfsg-1+b1 (binary)

liblorenef77-debian1 0.0.0~cvs20161116+dfsg-1+b1 (binary)

liblwgeom-2.4-0 2.4.4+dfsg-1 (binary) overridden

libmeasurement-kit-0.7.1-0 0.7.1-2 (binary)

libmjpegutils-2.1-0 1:2.1.0+debian-5 (binary)

libmpeg2encpp-2.1-0 1:2.1.0+debian-5 (binary)

libmplex2-2.1-0 1:2.1.0+debian-5 (binary)

libmumps-scotch-5.1.2 5.1.2-4+b1 (binary)

libmumps-seq-5.1.2 5.1.2-4+b1 (binary)

libmypaint-1.3-0 1.3.0-2 (binary)

libncbi6 6.1.20170106-2 (binary)

libnih-dbus1 1.0.3-10+b1 (binary)

libnih1 1.0.3-10+b1 (binary)

libnl-3-200 3.4.0-1 (binary)

libnl-genl-3-200 3.4.0-1 (binary)

libnova-0.16-0 0.16-2 (binary)

libnspr4 2:4.19-2 (binary) overridden

libnss3 2:3.37-1 (binary)

libomp-dev 6.0-3 (binary)

libopenexr23 2.2.1-4 (binary)

libow-3.1-5 3.1p5-2 (binary) overridden

libowcapi-3.1-5 3.1p5-2 (binary) overridden

libownet-3.1-5 3.1p5-2 (binary) overridden

libpari-gmp-tls5 2.9.5-1 (binary)

libpbbam 0.7.4+ds-1+b1 (binary) overridden

libpbdata 0~20161219-2 (binary)

libpbihdf 0~20161219-2 (binary)

libpetsc-complex3.9 3.9.1+dfsg1-1exp3 (binary)

libpetsc-real3.9 3.9.1+dfsg1-1exp3 (binary) overridden

libprocps6 2:3.3.14-1+b1 (binary)

libqpid-proton11 0.22.0-1 (binary)

librc1 0.34-2 (binary)

libsdl-console 2.1-5 (binary)

libsdl-image1.2 1.2.12-8 (binary)

libsdl-mixer1.2 1.2.12-14 (binary)

libsdl-net1.2 1.2.8-5 (binary)

libsdl-sound1.2 1.0.3-8 (binary)

libsdl-stretch-0-3 0.3.1-10 (binary)

libsdl-ttf2.0-0 2.0.11-4 (binary)

libsdl1.2debian 1.2.15+dfsg2-0.1 (binary) overridden

libsdl2-gfx-1.0-0 1.0.4+dfsg-1 (binary) overridden

libseed-gtk4-0 4.0.0+20161014+6c77960+dfsg1-5+b1 (binary)

libsfst1-1.4 1.4.7b-1+b1 (binary) overridden

libsignon-plugins-common1 8.59-2 (binary)

libslepc-complex3.8 3.8.3+dfsg1-1+b1 (binary) overridden

libslepc-complex3.9 3.9.1+dfsg1-1exp2 (binary) overridden

libslepc-real3.8 3.8.3+dfsg1-1+b1 (binary) overridden

libslepc-real3.9 3.9.1+dfsg1-1exp2 (binary) overridden

libsmpeg0 0.4.5+cvs20030824-7.2+b1 (binary)

libssh-gcrypt-4 0.8.0~20170825.94fa1e38-1 (binary) overridden

libstd-rust-1.25 1.25.0+dfsg1-2 (binary) overridden

libsvn1 1.10.0-1 (binary) overridden

libsystemd0 238-4 (binary)

libtcl8.5 8.5.19-4 (binary) overridden

libtcl8.6 8.6.8+dfsg-4 (binary) overridden

libtcl8.7 8.7.0~a1+dfsg-4 (binary) overridden

libtk8.5 8.5.19-3 (binary) overridden

libtk8.6 8.6.8-4 (binary) overridden

libtk8.7 8.7.0~a1-5 (binary) overridden

libudev1 238-4 (binary)

libusb-0.1-4 2:0.1.12-32 (binary)

libvulkan1 1.1.73+dfsg-1 (binary)

libwiredtiger0 2.9.3+ds-1 (binary)

libwmf0.2-7 0.2.8.4-12 (binary)

libwv-1.2-4 1.2.9-4.2+b2 (binary)

libxen-4.8 4.8.3+comet2+shim4.10.0+comet3-1+deb9u5 (binary)

libyaml-0-2 0.1.7-2 (binary)

libzeroc-ice3.7 3.7.1-1 (binary) overridden

libzorp6.0 6.0.10-4 (binary)

libzorpll-6.0-10 6.0.10.0-3 (binary)

libzthread-2.3-2 2.3.2-8 (binary)

openvswitch-common 2.8.1+dfsg1-6 (binary)

plasma-desktop 4:5.12.5-1 (binary) overridden

plasma-workspace 4:5.12.5-1 (binary) overridden

xfsprogs 4.15.1-1 (binary)