Lintian ReportsBETA

Edepends-on-essential-package-without-using-version

The tag is present in Lintian version 2.104.244. That is the most recent version we know about.

The package declares a depends on an essential package, e.g. dpkg, without using a versioned depends. Packages do not need to depend on essential packages; essential means that they will always be present. The only reason to list an explicit dependency on an essential package is if you need a particular version of that package, in which case the version should be given in the dependency.

Refer to Debian Policy Manual section 3.5 for details.

Visibility: error

Check: fields/package-relations

The following 5 source packages in the archive triggered the tag 5 times.

There were no overrides.