Lintian ReportsBETA

Pdebian-rules-uses-as-needed-linker-flag

Tag versions

The tag is present in Lintian version 2.104.328. That is the most recent version we know about.

The debian/rules file for this package uses the -Wl,--as-needed linker flag.

The bullseye toolchain defaults to linking with --as-needed and therefore it should no longer be necessary to inject this into the build process.

However, it is not safe to make this change if the package will target the buster distribution such as via backports to the buster-bpo / stable-bpo distribution or, during the bookworm cycle itself, the oldstable-bpo distribution.

This tag is experimental.

Visibility: pedantic

Check: debian/rules

The following 1633 source packages in the archive triggered the tag 1802 times.

We found 1 overrides. The tag performed 100% of the time.