Lintian ReportsBETA

Econtrol-interpreter-without-predepends

Tag versions

The tag is present in Lintian version 2.109.24. That is the most recent version we know about.

The package contains a preinst maintainer script that uses an unusual and non-essential interpreter but does not declare a Pre-Depends on the package that provides this interpreter.

preinst scripts should be written using only essential interpreters to avoid additional dependency complexity. Please do not add a Pre-Depends without following the policy for doing so (Policy section 3.5).

Please refer to Debian Policy Manual section 7.2 for details.

Visibility: error

Check: scripts

Renamed from:

Found no packages in the archive that triggered the tag.