Lintian Reports

E build-depends-on-build-essential

All reports of build-depends-on-build-essential for the archive. The extended description of this tag is:

You depend on the build-essential package, which is only a metapackage depending on build tools that have to be installed in all build environments.

Refer to Debian Policy Manual section 7.7 (Relationships between source and binary packages - Build-Depends, Build-Depends-Indep, Build-Conflicts, Build-Conflicts-Indep) for details.

Severity: important, Certainty: certain

Check: fields, Type: binary, udeb, source

Evolution of the build-depends-on-build-essential Lintian tag over the past 366 days:

The beforementioned graph for the build-depends-on-build-essential tag

Emitted (non-overridden): 2, overridden: 0, total: 2

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

dh-buildinfo 0.11+nmu1 (source)

geophar 16.08.4~dfsg1-1 (source)