Lintian Reports

E apache2-module-depends-on-real-apache2-package

All reports of apache2-module-depends-on-real-apache2-package for the archive. The extended description of this tag is:

The package is an Apache2 HTTPD server module but it depends on a real Apache2 package. Binary module packages must depend on the virtual apache2-api-YYYYMMNN package only in order to ease transitions in future.

In particular, module packages must not pull the full web server or any of its associated data packages as a dependency. That's left to the user.

Severity: serious, Certainty: certain

Check: apache2, Type: binary

Evolution of the apache2-module-depends-on-real-apache2-package Lintian tag over the past 366 days:

The beforementioned graph for the apache2-module-depends-on-real-apache2-package tag

Emitted (non-overridden): 73, overridden: 36, total: 109

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

gridsite 2.3.2-3+b1 (binary) overridden

libapache2-mod-apparmor 2.11.0-10 (binary) overridden

libapache2-mod-apreq2 2.13-5+b2 (binary)

libapache2-mod-auth-cas 1.1-2.1 (binary)

libapache2-mod-auth-gssapi 1.4.1-1+b1 (binary)

libapache2-mod-auth-kerb 5.4-2.3 (binary)

libapache2-mod-auth-mellon 0.13.1-1 (binary)

libapache2-mod-auth-openidc 2.1.6-1 (binary) overridden

libapache2-mod-auth-pubtkt 0.10-1 (binary)

libapache2-mod-auth-radius 1.5.8-1.3 (binary)

libapache2-mod-authn-webid 0~20110301-5 (binary)

libapache2-mod-authn-yubikey 1.0-1.2 (binary) overridden

libapache2-mod-authnz-pam 1.1.0-1 (binary)

libapache2-mod-dacs 1.4.38a-2 (binary)

libapache2-mod-encoding 20040616-6 (binary)

libapache2-mod-gnutls 0.8.2-3 (binary) overridden

libapache2-mod-intercept-form-submit 1.1.0-1 (binary)

libapache2-mod-jk 1:1.2.42-1 (binary)

libapache2-mod-log-sql 1.100-16.3 (binary)

libapache2-mod-log-sql-dbi 1.100-16.3 (binary)

libapache2-mod-log-sql-mysql 1.100-16.3 (binary)

libapache2-mod-log-sql-ssl 1.100-16.3 (binary)

libapache2-mod-lookup-identity 0.9.7-1 (binary)

libapache2-mod-mapcache 1.6.0-2 (binary) overridden

libapache2-mod-mono 3.8-3 (binary)

libapache2-mod-musicindex 1.4.1-2 (binary)

libapache2-mod-netcgi-apache 4.1.2-2 (binary)

libapache2-mod-nss 1.0.14-1+b1 (binary)

libapache2-mod-parser3 3.4.5-2 (binary) overridden

libapache2-mod-passenger 5.0.30-1+b1 (binary)

libapache2-mod-perl2 2.0.10-2+b1 (binary) overridden

libapache2-mod-php7.0 7.0.22-2 (binary) overridden

libapache2-mod-php7.1 7.1.8-1 (binary) overridden

libapache2-mod-proxy-uwsgi 2.0.15-2.1+b1 (binary) overridden

libapache2-mod-qos 11.40-1 (binary) overridden

libapache2-mod-r-base 1.2.8-1+b1 (binary)

libapache2-mod-removeip 1.0b-5.2 (binary)

libapache2-mod-rivet 2.3.4-1 (binary)

libapache2-mod-ruwsgi 2.0.15-2.1+b1 (binary) overridden

libapache2-mod-security2 2.9.1-3 (binary)

libapache2-mod-shib2 2.6.0+dfsg1-4 (binary) overridden

libapache2-mod-svn 1.9.7-2 (binary)

libapache2-mod-uwsgi 2.0.15-2.1+b1 (binary) overridden

libapache2-mod-webauth 4.7.0-5 (binary) overridden

libapache2-mod-webauthldap 4.7.0-5 (binary) overridden

libapache2-mod-webkdc 4.7.0-5 (binary) overridden

libapache2-mod-wsgi 4.5.17-1 (binary)

libapache2-mod-wsgi-py3 4.5.17-1 (binary)

libapache2-mod-xforward 0.6-1 (binary)

libapache2-mpm-itk 2.4.7-04-1 (binary)