W shlib-with-executable-stack

All reports of shlib-with-executable-stack for the archive. The extended description of this tag is:

The listed shared libraries declares the stack as executable.

Executable stack is usually an error as it is only needed if the code contains GCC trampolines or similar constructs which uses code on the stack. One possible source for false positives are object files built from assembler files which don't define a proper .note.GNU-stack section.

To see the permissions on the stack, run readelf -l on the shared library and look for the program header of type GNU_STACK. In the flag column, there should not be an E flag set.

Severity: normal, Certainty: possible

Check: shared-libs, Type: binary, udeb

Evolution of the shlib-with-executable-stack Lintian tag over the past 366 days:

History of shlib-with-executable-stack

Emitted (non-overridden): 27, overridden: 87, total: 114

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

fis-gtm-6.0-003 6.0-003-2 (binary) overridden

icedtea-7-jre-jamvm 7u51-2.4.6-1 (binary) overridden

jvm-7-avian-jre 0.7+20140401-1 (binary)

libalog0.4.1-base 0.4.1-2 (binary) overridden

libalog0.4.1-full 0.4.1-2 (binary) overridden

libaws2.10.2 2.10.2-4 (binary) overridden

libboost-context1.53.0 1.53.0-6+exp2 (binary)

libboost-context1.54.0 1.54.0-5 (binary)

libcephfs1 0.79-1 (binary)

libcephfs1 0.72.2-3 (binary)

libcuda1 331.49-1 (binary) overridden

libdbusada0.2 0.2-2 (binary) overridden

libecm0 6.4.4-2 (binary)

libffcall1 1.10+cvs20100619-3 (binary)

libffindex0 0.9.9.3-1 (binary) overridden

libgl1-nvidia-legacy-173xx-glx 173.14.39-1 (binary) overridden

libgl1-nvidia-legacy-96xx-glx 96.43.23-8 (binary) overridden

libgl1-nvidia-legacy-96xx-glx 96.43.23-90 (binary) overridden

libgmpada2 0.0.20131223-1 (binary) overridden

libgnadesqlite3-2 1.6.2-9 (binary) overridden

libgnatprj4.8 4.8.2-8 (binary)

libgnatprj4.9 4.9-20140330-3 (binary)

libgnatprj4.9 4.9-20140406-1 (binary)

libgnatprj4.9 4.9-20140411-1 (binary)

libgnomeada2.24.1 2.24.1-14 (binary) overridden

liblitl0 0.1.1+dfsg-3 (binary)

libnewlib0 1.18.0-6.2 (binary) overridden

libnvidia-compiler 331.49-1 (binary) overridden

libnvvm2 5.5.22-3 (binary) overridden

libpcscada0.7.1 0.7.1-4 (binary) overridden

libpolyorb3 2.8~20110207-5.1 (binary) overridden

libqthreads-12 1.6.8-10.3 (binary)

librados2 0.79-1 (binary)

librados2 0.72.2-3 (binary)

librc1 0.12.4+20131230-9 (binary)

libtemplates-parser11.6 11.6-4 (binary) overridden

libtexttools5 2.1.0-4 (binary) overridden

nvidia-libopencl1 331.49-1 (binary) overridden

nvidia-opencl-icd 331.49-1 (binary) overridden

slurm-llnl-basic-plugins 2.6.7-1 (binary) overridden

squeak-vm 1:4.10.2.2614-1 (binary)

syslinux-common 3:6.03~pre1+dfsg-1 (binary) overridden

xserver-xorg-video-nvidia-legacy-173xx 173.14.39-1 (binary) overridden

xserver-xorg-video-nvidia-legacy-96xx 96.43.23-8 (binary) overridden

xserver-xorg-video-nvidia-legacy-96xx 96.43.23-90 (binary) overridden