W native-package-with-dash-version

All reports of native-package-with-dash-version for the archive. The extended description of this tag is:

Native packaging should only be used if a piece of software was written specifically to be turned into a Debian package. In this case, the version number should not contain a Debian revision part.

Native source packages are sometimes created by accident. In most cases the reason is the location of the original source tarball. For version 1.0 source packages, dpkg-source determines whether they're non-native by looking for a file named <package>_<upversion>.orig.tar.gz in the parent directory, where <upversion> is the upstream version from the most recent debian/changelog entry. For version 3.0 packages, check debian/source/format for an erroneous "(native)" package format.

Severity: normal, Certainty: certain

Check: cruft, Type: source

Evolution of the native-package-with-dash-version Lintian tag over the past 366 days:

History of native-package-with-dash-version

Emitted (non-overridden): 48, overridden: 8, total: 56

The package names link to the relevant maintainer page and the corresponding report for the source package. The links go to the full maintainer report page, which includes info and experimental tags and overridden tags, rather than the default page that shows only errors and warnings.

binutils-avr 2.23.1-2.1 (source)


cln 1.3.3-1 (source)


coco-doc 20060919-2 (source)


cpqarrayd 2.3-3 (source) overridden


davical 1.1.1-1 (source)


dictem 1.0.4-2 (source)


dvswitch 0.9.1-1 (source)


ejabberd 2.1.11-1 (source)


focalinux 2010-09-3 (source)


fortunes-eo 20020729-4 (source)


francine 0.99.8orig-6 (source)


fusionforge 5.3~rc4+20140324-1 (source)


gcc-avr 1:4.8-2.1 (source)


gdb-avr 7.6-1 (source)


gnat-4.6 4.6.4-4 (source)


gnat-4.8 4.8.2-8 (source)


gnat-4.9 4.9-20140411-4 (source)


id-utils 4.6+git20120811-4 (source)


idl-font-lock-el 1.5-9 (source)


ircmarkers 0.14-3 (source)


jless 382-iso262-3 (source)


libcorelinux 0.4.32-7.3 (source)


libcsoap 1.1.0-17.2 (source)


libexplain 1.4.D001-1 (source)


libtext-header-perl 1.03-2 (source)


mailsync 5.2.2-3 (source)


manpages-posix 2.16-1 (source)


members 20080128-5 (source)


moon-buggy 1.0.51-9.1 (source)


ocaml-book 1.0-5 (source)


pimd 2.1.8-2 (source) overridden


psrip 1.3-7 (source) overridden


purity-off 0-3 (source)


python-defaults 2.7.5-5 (source) overridden


python-stdlib-extensions 2.7.5-1 (source) overridden


python3-defaults 3.3.4-1 (source) overridden


python3-defaults 3.4~rc1-1 (source) overridden


python3-stdlib-extensions 3.3.4-1 (source) overridden


scratchbox2 2.2.4-1debian1 (source)


scribble 1.11-1 (source)


signify 1.14-1 (source)


smsclient 2.0.8z-10 (source)


squid-prefetch 1.1-3 (source)


sredird 2.2.1-1.1 (source)


sword-comm-mhcc 1.1-4 (source)


sword-dict-naves 1.1-3 (source)


sword-text-web 1.4-3 (source)


tinyeartrainer 0.1.0-2 (source)


tk-brief 5.9-1.1 (source)


trn 3.6-23 (source)


tsocks 1.8beta5-9.2 (source)


vmfs-tools 0.2.5-1 (source)


w3c-dtd-xhtml 1.2-4 (source)


webcamd 0.7.6-5 (source)


wmxres 1.2-10 (source)


xbs 0-8 (source)